Poke Pelago time not advancing

Does anyone know how to fix the problem of the pokepelago time not changing on ultra moon? im using Mac and it will not move passed 24 hours remaining

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

try the following: go to Emulation > Configure > System > Clock > FIxed Time and set something like 2018-08-15 5:00AM, launch your game, then change it later.

Pretty sure the games incur a time penalty if you’ve tried to change the time before. Not sure for every island but I know the glitch for advancing time to level up pokemon was fixed in USUM.

i think you can use PKHex to change in game clock time, probably works fine. backup your save before trying.

Same to me, It happened from around two weeks ago, I have my mac time set up automatically.citra_log.txt (182.7 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

does anyone knows how to fix this?

Any new in fos for Fix the Time issue?

i think there is no new fix in this… this is a well known problems in using a emulator…

I just changed the date before starting the game to go back a couple of days…

and it worked, it was US/UM tho

Closing topic as information may be out of date. Please create your own support topic if you’re experiencing a similar issue.