Pokemon Alpha Sapphire Freezing

Issue:
The game randomly freezes at seemingly sporadic points. It always gets to at least the scene where you enter your new house. At a certain point, the game will freeze and no input will work until the ROM is reset.

System Information

  • Operating System: Windows 10
  • CPU: Intel i3 3.40GHz
  • GPU: GTX 1050 TI
  • Citra Version (found in title bar): Citra Canary 1959
  • Game: Pokemon Alpha Sapphire
  • Screenshot of Issue (include the full Citra window including titlebar): N/A

Diagnostic Log
citra_log.txt (109.5 KB)

Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1959 HEAD-651c9d0
Operating System                              Windows 7 (6.1)
CPU                                                   Intel(R) Core(TM) i3-3240 CPU @ 3.40GHz | AVX
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1050 Ti/PCIe/SSE2
GPU Driver Version                            456.71
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.
[   0.034246] Config <Info> core/settings.cpp:operator():75: Core_CPUClockPercentage: 400

^ Yea, this is a good way to make your game freeze. Go to Emulation>Configuration>System and set your CPU Clock Speed back to 100%. You shouldn’t be messing with this setting unless you know what you’re doing.