Pokemon Alpha Sapphire Intro Crash

Issue:
Pokemon Alpha Sapphire crashes during in the middle of intro sequence. Worked around by skipping intro sequence, but when the intro is skipped to the “press start” screen, pressing start leads to a black screen, then citra crashes.

System Information

  • Operating System: Android Version 8.0.0 on Samsung S7
  • CPU: Snapdragon 820/Exynos 8890
  • GPU: * Exynos: [Mali-T880 MP12]
  • Snapdragon: [Adreno]530
  • Citra Version (found in title bar): unsure, but app version on May 26, 2020
  • Game: Pokemon Alpha Sapphire
  • Screenshot of Issue (include the full Citra window including titlebar):
    freezes here

Diagnostic Log
citra_log.txt (2.8 KB)

Bump. Been having this exact issue. Same game, will try to get crash log.

bump. is there some way to fix this? perhaps an interpretation of the crash log

Hm, the log doesn’t have useful information did you accidentally reopen Citra? The log gets cleared every time you open Citra so after it crashes do not reopen Citra, go straight to where the log file is using your phone’s file explorer and upload.

citra_log.txt (4.5 KB)

bump, is this the right log? any help i appreciate, i really wanna play

Hm, still doesn’t mentioned you tried to start a game even :confused: you aren’t reopening Citra after it crashes right? You go straight to the log folder with your file explorer on your phone?

when it crashes it just returns to the game selection screen, i’m not reopening citra, it just returns to the game selection screen after crashing. I think it reopens itself after crashing.

what i did was, it crashes, returns to the game selections screen, then i go straight to the log folder. i think it refreshes the log before i get to retrieve it.

Ah ok, hm… I will assume the rom might be corrupted and you should try redump it. Follow the guides below and have at least 4GB free space on your Nintendo 3DS’s SD card:


I managed to retrieve the logs during the crash, i closed the app before it could reopen.
citra_log.txt (43.0 KB)

might help, do i really need to redump? or is it some other problem

citra_log.txt (43.0 KB)

i just redumped it, it still crashes exactly the same, please help

i’ve disabled hardware shaders, and it doesn’t crash anymore, yet it runs at a very slow pace, around 25% speed

there must be a better solution right?

bump, please need answers

Debug <Critical> video_core/renderer_opengl/gl_shader_util.cpp:operator():105: Assertion Failed!
Shader not linked

Hm… Since Citra on Android is relatively new I don’t know much. I’m not sure if it will help but try change the log filter to *:Debug then generate a new log to upload. You might need to upload it to Google Drive then link it here as it might become large.

A new update was released today, Beta 6. Check if that fixes it if not do the above with changing the log filter and upload a new log.

citra_log.txt (25.9 KB)
i just updated to version beta 7
still crashes, but now doesn’t even get to the intro cutscene, it crashes after selecting a language then black screen, then crashes.

i just tried the mmj build, it definitely could work almost flawlessly… thank you

So you are not willing to help us by providing a new log with the Debug filter which I mentioned in my previous reply?

i’ve sent it through the send feedback option through the app after it crashes

Ok, though I think we would need a Debug log. Open the config file in a text editor (the config should be in the config folder). Then just replace *:Info with *:Debug

Then play until it crashes and upload the log here again as you did before. Though you might need to zip it and upload it to like Google Drive instead, then link it here.

When you said you tested Beta 7, was it the Play Store version?