Pokemon Alpha Sapphire: Passersby don't work/show up

Issue:
I got on a room to see if I could battle, and no one popped up in my passersby section.
I also tried regenerating console ID but same issue.

System Information

  • Operating System: MacBook Pro (Retina, 13-inch, Early 2015)
  • CPU: 2.7 GHz Intel Core i5
  • GPU: Intel Iris Graphics 6100 1536 MB
  • Citra Version (found in title bar): Canary 1774
  • Game: Pokemon Alpha Sapphire
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (4 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Afaik, Streetpass is not emulated yet.

Then how am I supposed to play with others? My friend also got in the room but he could see other people to battle/trade with.

There should be a NPC in-game to initiate local trade/battle.

I already talked to the NPC and got access to local trade/battle, its just that no one shows up

Hm, just noticed this in your screenshot:

image

Your log is cut off as well which might be why, try turn off Disk Shader Cache. Your rom might be corrupted so perhaps try a redump using the guides below to make sure it is clean. Have at least 4GB free space on your Nintendo 3DS’s SD card:


citra_log.txt (108.1 KB)

System Information for Support

Client Version                                Canary 1774 HEAD-5442e61
Operating System                              macOS Mojave (10.14)
CPU                                           Intel(R) Core(TM) i5-5257U CPU @ 2.70GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             Intel(R) Iris(TM) Graphics 6100
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • System configuration block 0x90000 appears to be corrupted. Please attempt the steps outlined in our FAQ https://citra-emu.org/wiki/faq/

how do i deal with the corrupted system config block?

nvm i found the solution. Thx for the help!!!

1 Like