Pokemon Legends Arceus got low fps and very lag while playing

Hello, i have just launched Yuzu today and play PLA but some problem is the fps is very low and while i’m playing is very lag like is hard to move my character and slow frame. I keep playing but later Yuzu just freeze and close. So how can i fix this problem?
Here is my system infomation:

  • Operating System: Windows Home Single Language
  • CPU: Intel® Core™ i5-6200U CPU @ 2.30GHz 2.40GHz
  • GPU: Intel® HD graphics 520
  • Shader Version: 5.1
  • OpenGL* Version: 4.6
  • OpenCL* Version: 2.1
  • Vulkan* Version: 1.2.135
  • Yuzu version: 903
    Log:
    yuzu_log.txt.old.txt (4.7 KB)
    The log i’m playing at OpenGL said is too big so i cant upload

System Information for Support

Client Version                               yuzu 903
Operating System                             Windows 10 Version 2009
CPU                                          Intel(R) Core(TM) i5-6200U CPU @ 2.30GHz | AVX2 | FMA
Graphics API                                 Unknown (?)
Graphics Renderer                            ?
GPU Driver Version                           ?
CPU Accuracy                                 Auto
GPU Accuracy                                 High
Docked Mode                                  [x]
CPU Multicore                                [x]
Async GPU                                    [x]
Async Shaders                                [ ]

Here’s some issues I found with your log that might help.

  • Your graphics card is missing the required Vulkan extension (VK_EXT_robustness2). Please update your graphics driver.

My OpenGL log is here
https://drive.google.com/file/d/1OgMXymD7t9GotgF0ENBQLfySl1dGWXK-/view?usp=sharing

Update to the latest GPU driver to get Vulkan support: Intel® Graphics – Windows* DCH Drivers

Besides that, expect very low performance, both the CPU and GPU are on the slow side, and only 4GB of RAM won’t be enough to run most games, the minimum required is 8GB: Quickstart Guide - yuzu

My GPU is already up to date but i cant play at Vulkan (got freeze right away) , the OpenGL works more good for me still the fps mostly at 10-15
You mentioned about RAM is that the installed RAM btw?

Yes the installed RAM needs to be at least on 8GB.
Linked you the wrong driver, my bad, here is the correct one: https://www.amd.com/en/support/graphics/amd-radeon-r5-series/amd-radeon-r5-300-series/amd-radeon-r5-m335
Keep in mind both GPU drivers must be up to date (both the Radeon and Intel GPUs), and manually updated (neither Windows Update nor the vendor drivers will be up to date).

Radeon GPUs are over 3 times slower in OpenGL compared to Vulkan.

I also update my Radeon too but still slow but i think my RAM is not enough for running
Still thank you for support

1 Like