Pokemon moon black screen

i was playing the game but some parts of the screen turn black until i save state and reload, but it keeps doing it, is there any way i can prevent it from doing it and enjoy my gaming experience?

  • Operating System: 64-bit operating system x64 based processor
  • CPU: Intel ® Core ™ i3-6100U CPU @ 2.30GHz
  • GPU: Intel ® HD Graphics 520
  • Citra Version (found in title bar): 1678 Nightly
  • Game: Pokemon Moon

citra_log.txt (24.3 KB)

System Information for Support

Client Version                                Nightly 1678 HEAD-e33677b
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-6100U CPU @ 2.30GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 520
GPU Driver Version                            23.20.16.4973
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [ ]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

i tried but nothing happened

GPU Driver Version: 23.20.16.4973

This driver is outdated, you need to update.

Download this driver: https://downloadmirror.intel.com/28289/a08/win64_25.20.100.6373.zip then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

After you have installed 6373, download and install igfx_win10_100.9168.exe from: https://downloadcenter.intel.com/download/30148/Intel-Graphics-Windows-10-DCH-Drivers
direct link: https://downloadmirror.intel.com/30148/a08/igfx_win10_100.9168.exe

10x resolution is overkill for integrated graphics and probably won’t be able to handle it. If your screen is only 1080p, set it to 4x. If it’s lower like 1366x768 then set it to 3x.

Enable Accurate Multiplication, Shader JIT and Disk Shader Cache in the Advanced graphics settings in Citra configuration.