Pokemon Moon error : looking for .app files

Issue:
I’m trying to get a randomized moon to work, but it keeps giving the same error. The file seems fine, 4Gigs or so and seems to show correctly in the list of games. It seems to be looking for .app files in folders that obviously aren’t there. Any ideas?

T.I.A

System Information

  • Operating System: Win 10 x64
  • CPU: i72200-K
  • GPU: gtx970
  • Citra Version (found in title bar): 9c58805 (tried latest as well, didn’t work)
  • Game: Pokemon Moon
  • Screenshot of Issue (include the full Citra window including titlebar):

Log:

[ 0.000000] Frontend citra_qt/main.cpp:CheckForUpdates:445: Unable to start check for updates
[ 0.000667] Frontend citra_qt/main.cpp:BootGame:583: Citra starting…
[ 1.049343] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:488: GL_VERSION: 3.3.0 NVIDIA 385.41
[ 1.049919] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:489: GL_VENDOR: NVIDIA Corporation
[ 1.050179] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:490: GL_RENDERER: GeForce GTX 970/PCIe/SSE2
[ 1.055176] Loader core/loader/ncch.cpp:Load:159: Program ID: 0004000000175E00
[ 1.055587] Service.FS core/file_sys/ncch_container.cpp:OpenFile:107: Failed to open C:\Users\DAltu\AppData\Roaming/Citra/sdmc/Nintendo 3DS/00000000000000000000000000000000/00000000000000000000000000000000/title/0004000e/00175e00/content/00000000.app
[ 1.056032] Core core/core.cpp:Load:107: Failed to load ROM (Error 1)!

How did you dump the original game?

I used a tutorial to dump and decrypt from my 3ds,Dumped file worked perfectly fine before too.

This is harmless. Citra doesn’t detect the update for the game.

We generally don’t provide support for ROM hacks as we don’t know what was done to the ROM.

But why is it looking for the update in such an odd, non-existant folder? And even with the .app extension? Isn’t this weird?
Should it still boot then, if you’re saying it’s ‘harmless’?

Where would I put the update on windows instead of the MacOS default it shows in the error code? And what extension would it be? Because I believe I’ve got it, but it’s a bin and the folders they mention don’t exist.

And well I’m sorry about that but I just felt like this had nothing to do with the actual rom.

Citra checks for the update on boot. It’s just saying it doesn’t find one (the .app file). Updates are optional. You don’t need it to boot the game. Your issue is with your ROM hack.

Hmm, alrighty if you say so.

Thanks for the info.

EDIT: For anyone wondering, he was right.

Say if I want to place an update, where do I do that?