Pokemon Moon Glitch

Issue:
When i open pokemon in citra it starts glitching and starts turning wierd . The glitch cannont be seen in scrrenshot

System Information

  • Operating System: Windows 7
  • CPU: 4
  • GPU: Intel® HD Graphics Family
  • Citra Version (found in title bar): HEAD - e1bb198
  • Game: Pokemon Moon
  • Screenshot of Issue (include the full Citra window including titlebar):

Log:

Paste your entire console window log here. [ 0.000000] Frontend citra_qt/main.cpp:BootGame:428: Citra starting…
[ 0.424714] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:488: GL_VERSION: 3.3.0 - Build 9.18.10.2973
[ 0.424769] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:489: GL_VENDOR: Intel
[ 0.424802] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:490: GL_RENDERER: Intel® HD Graphics 4400
[ 0.529101] Loader core/loader/ncch.cpp:Load:177: Program ID: 0004000000175E00
[ 0.529503] Service.FS core/file_sys/ncch_container.cpp:OpenFile:107: Failed to open C:\Users\ANSUMAN\AppData\Roaming/Citra/sdmc/Nintendo 3DS/00000000000000000000000000000000/00000000000000000000000000000000/title/0004000e/00175e00/content/00000000.app
[ 0.556220] Loader core/hle/kernel/process.cpp:ParseKernelCaps:108: ExHeader kernel version: 2.50
[ 0.561978] Service.CFG core/hle/service/cfg/cfg.cpp:SetPreferredRegionCode:613: Preferred region code set to 0
[ 0.562030] Service.CFG core/hle/service/cfg/cfg.cpp:SetPreferredRegionCode:621: System language 1 does not fit the region. Adjusted to 0
[ 0.592352] Service.SRV core/hle/service/sm/srv.cpp:RegisterClient:48: (STUBBED) called
[ 0.988533] Service.SRV core/hle/service/sm/srv.cpp:EnableNotification:70: (STUBBED) called
[ 0.995581] Service.APT core/hle/service/apt/apt.cpp:GetLockHandle:431: (STUBBED) called handle=0x00038009 applet_attributes=0x00000000
[ 1.009203] Service.APT core/hle/service/apt/apt.cpp:SetScreenCapPostPermission:870: (STUBBED) screen_capture_post_permission=0
[ 1.011420] Service.NDM core/hle/service/ndm/ndm.cpp:OverrideDefaultDaemons:203: (STUBBED) default_daemon_bit_mask=0x0000000F
[ 1.011820] Service.NDM core/hle/service/ndm/ndm.cpp:SuspendDaemons:89: (STUBBED) daemon_bit_mask=0x00000009
[ 1.017798] Service.APT core/hle/service/apt/apt.cpp:NotifyToWait:408: (STUBBED) app_id=768
[ 1.025444] Service.APT core/hle/service/apt/apt.cpp:AppletUtility:733: (STUBBED) called command=0x00000007, input_size=0x00000004, output_size=0x00000001, input_addr=0x0FFFFF48, output_addr=0x0FFFFF14
[ 1.026257] Service.APT core/hle/service/apt/apt.cpp:AppletUtility:733: (STUBBED) called command=0x00000004, input_size=0x00000001, output_size=0x00000001, input_addr=0x0FFFFF10, output_addr=0x0FFFFF14
[ 1.032362] Service.FS core/hle/service/fs/fs_user.cpp:InitializeWithSdkVersion:806: (STUBBED) called, version: 0x0B0401C8
[ 1.069806] Service.SRV core/hle/service/sm/srv.cpp:Subscribe:146: (STUBBED) called, notification_id=0x209
[ 1.101042] Service.DSP core/hle/service/dsp_dsp.cpp:LoadComponent:148: Firmware hash: 0x943f5565dbcf6767
[ 1.101106] Service.DSP core/hle/service/dsp_dsp.cpp:LoadComponent:152: Structures hash: 0x93e48663943cad39
[ 1.101145] Service.DSP core/hle/service/dsp_dsp.cpp:LoadComponent:157: (STUBBED) called size=0xC25C, prog_mask=0x000000FF, data_mask=0x000900FF, buffer=0x0062917C
[ 1.104596] Service.DSP core/hle/service/dsp_dsp.cpp:RegisterInterruptEvents:248: Registered type=2, pipe=2, event_handle=0x00098021
[ 1.105572] Service.DSP core/hle/service/dsp_dsp.cpp:GetSemaphoreEventHandle:174: (STUBBED) called
[ 1.106447] Service.DSP core/hle/service/dsp_dsp.cpp:SetSemaphoreMask:469: (STUBBED) called mask=0x00002000
[ 1.107840] Audio.DSP audio_core/hle/pipe.cpp:PipeWrite:134: Application has requested initialization of DSP hardware
[ 1.108667] Service.DSP core/hle/service/dsp_dsp.cpp:SetSemaphore:271: (STUBBED) called
[ 1.114735] Service.DSP core/hle/service/dsp_dsp.cpp:SetSemaphore:271: (STUBBED) called
[ 1.395076] Service.LDR core/hle/service/ldr_ro/ldr_ro.cpp:LoadCRR:202: (STUBBED) called, crr_buffer_ptr=0x0821E000, crr_size=0x00007000, process=0xFFFF8001
[ 1.455729] Service.GSP core/hle/service/gsp_gpu.cpp:AcquireRight:702: called
[ 1.457313] Service.GSP core/hle/service/gsp_gpu.cpp:RegisterInterruptRelayQueue:397: called, flags=0x00000001
[ 1.778386] Service.FRD core/hle/service/frd/frd.cpp:SetClientSdkVersion:158: (STUBBED) called, version: 0x0B0401C8
[ 1.779191] Service.FRD core/hle/service/frd/frd.cpp:GetMyPresence:35: (STUBBED) called
[ 1.781447] Service.FRD core/hle/service/frd/frd.cpp:GetFriendKeyList:53: (STUBBED) called, unknown=0, frd_count=100, frd_key_addr=0x33C0277C
[ 1.818949] Service.BOSS core/hle/service/boss/boss.cpp:InitializeSession:40: (STUBBED) unk_param=0x0000000000000000, translation=0x00000020, unk_param4=0x00000000
[ 1.820200] Service.NDM core/hle/service/ndm/ndm.cpp:ResumeDaemons:104: (STUBBED) daemon_bit_mask=0x0000000B
[ 1.820436] Service.NDM core/hle/service/ndm/ndm.cpp:ResumeDaemons:104: (STUBBED) daemon_bit_mask=0x0000000F
[ 1.823377] Service.BOSS core/hle/service/boss/boss.cpp:GetStorageEntryInfo:838: (STUBBED) called
[ 1.824568] Service.BOSS core/hle/service/boss/boss.cpp:UnregisterStorage:66: (STUBBED) called
[ 1.825495] Service.BOSS core/hle/service/boss/boss.cpp:RegisterStorageEntry:827: (STUBBED) unk_param1=0x00001648, unk_param2=0x00000000, unk_param3=0x00100000, unk_param4=0x00000001, unk_param5=0x00000001
[ 1.931002] Service.APT core/hle/service/apt/apt.cpp:SetScreenCapPostPermission:870: (STUBBED) screen_capture_post_permission=3
[ 2.039306] Service.FRD core/hle/service/frd/frd.cpp:GetMyFriendKey:97: (STUBBED) called
[ 2.083402] Service.FRD core/hle/service/frd/frd.cpp:GetMyFriendKey:97: (STUBBED) called
[ 2.855738] Service.FRD core/hle/service/frd/frd.cpp:GetMyFriendKey:97: (STUBBED) called
[ 2.961643] Service.LDR core/hle/service/ldr_ro/cro_helper.cpp:ApplyStaticAnonymousSymbolToCRS:528: CRO “LangSelect” exports 0 static anonymous symbols
[ 2.962373] Service.LDR core/hle/service/ldr_ro/cro_helper.cpp:ApplyModuleExport:954: CRO “LangSelect” exports 0 indexed symbols to “|static|”
[ 2.962456] Service.LDR core/hle/service/ldr_ro/cro_helper.cpp:ApplyModuleExport:971: CRO “LangSelect” exports 2 anonymous symbols to “|static|”
[ 2.962623] Service.LDR core/hle/service/ldr_ro/ldr_ro.cpp:LoadCRO:445: CRO “LangSelect” loaded at 0x006AC000, fixed_end=0x006B7000
[ 4.144724] Service.FS core/hle/service/fs/archive.cpp:HandleSyncRequest:172: (STUBBED) File command OpenLinkFile Path: [Binary: 000000000000000000000000]

In order to save a copy of the log, follow this guide:mmunity.citra-emu.org/t/how-to-upload-the-log-file/296

Are you talking about Professor Kukui adjusting his camera if yes then that’s normal.

can u tell me your email adress as this site doesnt allow sending videos i can send the glitc to ur email

Just post a link to that video uploaded somewhere else instead of posting it straight here.

Where do i put it . Can u recommed some sites to put . except youtube

best i could get see the background has turned white and the dog or whatever that pokemon is called has turned red and its glitching pretty badly

its not the fault of the rom as it worked perfectly in windows 10 but now my pc is having issues so i cant play in it

It was the fault of your emulator but i used a different emulator and it worked very well . Good Bye

I got the solution but my brothe laptop has this problem error seriously improve your emulator

he is stubborn and he wants to use this emu as his friends do

32-bit devices (which that device looks like) is not supported.

I would love to know of another 3DS emulator out there - we might have some competition, which would improve 3DS emulation as a whole.

3 Likes

probably some emulator that promises 100% speed in all the pokemon games on a celeron cpu and even online capabilities :open_mouth:

anyway i just fired up the intro in pokemon moon and it works just fine in the latest canary.

Thanks for reply , Sorry for being rude earlier i was a little frustrated

Its 64-Bit i checked

Did you download Citra from the official website? Error 0xc7b probably means that either your OS is 32-bit, or the program doesn’t have required DLLs for it to function (and that mostly happens on unofficial builds)

i download from the official website

Could you please share a screenshot of Control Panel -> System? You only need to capture the system + OS specs, feel free to hide your license ID.

RAM is very low::persevere:

This may be unrelated, but please try updating Windows 7 to Windows 7 Service Pack 1.