Pokemon Mystery Dungeon: Gates to Infinity Keeps Crashing

Issue:
Pokemon Mystery Dungeon: Gates to Infinity will crash every time I open it, without any warning or error message. I looked at a few other similar posts and tried to change my audio device and resolution and none of it worked. I also uninstalled Citra multiple times, as well as deleted it’s %appdata% folder, and it still kept crashing. It is also only this game as I tried others and they worked fine.

System Information

  • OS: Windows 10 Home
  • CPU: Intel i5-10600KF @4.10 GHz
  • GPU: Nvidia RTX 2060
  • Citra Version (found in title bar): 1621
  • Game: Pokemon Mystery Dungeon: Gates to Infinity

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

citra_log.txt (11.7 KB)

System Information for Support

Client Version                                Nightly 1621 HEAD-df9e230
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-10600KF CPU @ 4.10GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce RTX 2060/PCIe/SSE2
GPU Driver Version                            442.23
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Hi, please try this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure… then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Thank you for responding. I changed that when the bot pointed it out, and it stayed open for a little longer, but still crashed.

Did you also follow the rest of the instructions I gave? They all need to be performed for the bug to be resolved if you are indeed experiencing that bug.

If you did, then please try to disable hardware shaders, then try launching your game again.

Yes, I did follow the instructions. Disabling hardware shaders did not do anything either.

Let’s try a manual build to rule out any issues in Appdata.
Download citra-windows-mingw-20200910-df9e230.7z (direct link) from https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1621
Extract the archive somewhere on your pc. Doesn’t matter where so long as it’s not in Appdata.
The resulting folder, ‘‘nightly-mingw’’ has everything you need to use citra, but it’s important to create a folder called user inside of it to force citra to create the files and folders it usually creates/uses in appdata, in that user folder instead.
After that, launch citra by running citra-qt.exe and then run your game.

Thank you so much for your help. That solved it!