Pokemon Omega Ruby Black Screen when trying to equip HM

Issue:
Enter a description of your issue here, in full detail.
So I already have a few hours in Pokemon Omega Ruby, even made it up to the 2nd gym, and I am about to equip an HM-Flash (also tried with HM-Cut) to one of my Pokemon and after being asked “Which move should be forgotten?” the moment it is about to let me choose the move to be switched, it changes to a black screen and it doesn’t load again at all.

In addition to that, some of the UI backgrounds appear to be missing, such as when choosing to rename a Pokemon (check screenshots)

System Information

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (868 Bytes)

No game was booted in your log. If you are experiencing a crash then do not open citra again until after you posted the log as it gets purged when you reopen citra.
For more information, see How to Upload the Log File

Attached here is my most recent log

citra_log.txt (50.3 KB)

System Information for Support

Client Version                               Nightly 2014  HEAD-6d4e462
Operating System                             Windows 10 Version 22H2 (Build 19045.3570)
CPU                                          Intel(R) Core(TM) i5-8265U CPU @ 1.60GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            Intel(R) UHD Graphics 620
GPU Driver Version                           31.0.101.2125
CPU JIT                                      [x]
Hardware Shader                              [ ]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.