Pokemon Omega Ruby crash facing Koffing

Yo, I’m playing Pokemon Omega Ruby on Steam OS but every time I encounter a trainer with a Koffing, Citra crashes.
There is one trainer at route 113 in a heap of ash, I get until he jumps out, the pokeball is thrown and the glittering effect of the pokemon occurs. Then the game / Citra freezes and crashes.

I tried to avoid him but now I have to face a guy of Team Magma (Tabitha) at Meteor Falls with a Koffing and the game crashes again.

Probably similar error on GitHub
I think this person has the same error like me (just didn’t identify Koffing as the problem).
Link to similar problem at GitHub

System Information

  • Operating System: Steam OS 3.4.8
  • CPU: AMD APU Zen 2 4c/8t, 2.4-3.5GHz
  • GPU: 8 RDNA 2CUs, 1.0-1.6GHz
  • Citra Version: Nightly 1940
  • Citra Version: Nightly 1967
  • Game: Pokemon Omega Ruby

Diagnostic Log

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

Please try out the latest Nightly’s appimage build: Release nightly-1967 · citra-emu/citra-nightly · GitHub

It’s still crashing, I updated the link at my initial question to a folder with the logfiles of different nightly versions.

Diagnostic Log
Link to logfiles

Hello, I ran into the exact same problem. As soon as I stumble upon these two Pokemon somewhere, the emulator crashes.
I am using arch linux and AMD graphics. I also use the latest version available on Flathub (Nightly 1967). Tried everything that was possible, but the result is the same. I really hope this issue can be resolved.

System description:

  • OS: Arch Linux x86_64
  • Kernel: 6.4.9-zen1-1-zen
  • CPU: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx (8) @ 2.100
  • GPU: AMD ATI Radeon Vega Series / Radeon Vega Mobile Series

citra_log.txt (50.1 KB)
citra_log.txt.old.txt (74.3 KB)

Can you please also send a log file from the crash happening in the AppImage?

Ok first I wanted to use the appimage build suggested by @SleepingSnake, but then I couldn’t figure out how to copy my savefiles. Because of that I instead updated my flatpak Citra to nightly 1967 and I thought that’s the same.

But now I figured out how to copy savefiles (if someone cares, I copied the sdmc folder, might contain all savefiles).
I tried it with the citra-qt.AppImage from the Citra nightly 1967 repo suggested by @SleepingSnake, using my safefile and it didn’t crash. So the problem might be somwhere in between the appimage and the flatpak version?

I also uploaded the logfiles of the successful try.
(I spoke to the trainer in the heap of ash, he threw his pokeball with Koffing and I was at the attack menu. Then I stopped the emulation.)

Since my posts are marked as advertisement because of the platform I used to share the logfiles… just lost here are the files.

citra_log_nightly_1967_flathub.txt (35.1 KB)
citra_log_nightly_1967_qt-appimage.txt (366.7 KB)

It works! Using the appimage format really fixes this problem. Tested on archlinux. Thank you so much for your help.

Okay, good to know that the issue is either with our Flatpak build, or the Mesa driver that ships with the Flatpak build.

So how did you fix it from crashing?

@Bhankhill There is no real fix yet. Only a workaround by using the GitHub Appimage instead the flatpak version.

Okay so i got the appimage but can i transfer my save file or is it easier to just start over???

Also im playing on steam deck is it possible to use appimage on gamemode rather than in desktop mode?

You have to find out yourself, I will wait until it is fixed, since it’s not an addiction to play Pokémon. And I’m to lazy to mess around in the steamdecks os right now.
But I think somehow it should be possible.

citra_log.txt (40.8 KB)
Koffing And Ninja Kid Hiding In The Ash Pile Causes the game to crash on steam deck please help im new to software stuff lol

I’m now having this issue. Using Citra on the steam deck via emu deck, whenever koffing or torkoal is used the game freezes as the poke ball opens. Is this just an issue with Citra not being able to handle certain effects?

I’ve seen a lot of people say to install the appimage, but not sure that’s possible on steam dec?