Pokemon Omega Ruby Eating inputs

Issue:
Omega Ruby has started eating most my inputs only taking seemingly random ones except for moving my character in the overworld. This includes inputs from my wireless controller, keyboard and clicking on the touchscreen with my mouse. There is no visual or audio lag. If I hold the button, once it takes the input, it recognises that it’s being held.

It was fine yesterday but after the update today it doesn’t work properly. I can’t remember which version I was on before.

System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 3700X
  • GPU: NVidia GeForce GTX 1070
  • Citra Version (found in title bar): Nightly 1633 and Canary 1869
  • Game: Pokémon Omega Ruby Rom Hack(Rising Ruby)
  • Screenshot of Issue (include the full Citra window including titlebar): Would need video.

Diagnostic Log
Nightly citra_log.txt (77.7 KB)
Canary citra_log.txt (121.0 KB)

System Information for Support

Client Version                                Canary 1869 HEAD-f63770c
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 7 3700X 8-Core Processor             
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1070/PCIe/SSE2
GPU Driver Version                            456.38
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.