Pokemon Omega Ruby going too fast on Citra Nightly

I just updated to the latest version of Citra Nightly, and when I reloaded my game, the speed was going from 200% to 500%

I kinda just want to play the game with the normal pace, is there any way I could regulate the speed?

System Information

  • Operating System: Windows 10
  • CPU:
  • GPU: nvidia geforce gtx 1660 super
  • Citra Nightly
  • Game: Pokemon Omega Ruby and Alpha Sapphire
  • Screenshot of Issue:

Diagnostic Log
citra_log.txt (4.8 KB)

System Information for Support

Client Version                                Nightly 1488 HEAD-b96b7ab
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
1 Like

System Information for Support

Client Version                                Nightly 1488 HEAD-b96b7ab
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Enable Limit Speed Percent in the Citra configuration. Maybe you accidentally pressed the hotkey CTRL+Z :stuck_out_tongue:

1 Like