Pokemon Omega Ruby lag

Issue:
The game runs ok most of the time, but when i change my location or enter a battle it lags for a bit, the game moves slow, and the music just glitches, as i said most of the time is ok, but i came to a part where it,s annoying and i don.t know what to do.
I don,t know what settings should i use, what do you guys recommend.

System Information

  • Operating System: Windows 10
  • CPU: Intel Celeron 2955U
  • GPU: Intel Graphics 620
  • Citra Version (found in title bar): Citra Nightly 1399
  • Game: Pokemon Omega Ruby

Diagnostic Log
citra_log.txt (72.6 KB)

System Information for Support

Client Version                                Nightly 1397 HEAD-020cd56
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics
OpenGL Version                                3.3.0
GPU Driver Version                            10.18.15.4248
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. https://downloadcenter.intel.com/product/80939/Graphics-Drivers
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

System Information for Support

Client Version                                Nightly 1397 HEAD-020cd56
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics
OpenGL Version                                3.3.0
GPU Driver Version                            10.18.15.4248
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. https://downloadcenter.intel.com/product/80939/Graphics-Drivers
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Same thing, nothing changed.