Pokemon Rising Ruby crashes immediately upon loading

Issue:
I’m on the latest build, and when I open Citra, then open Pokemon Rising Ruby (my only ROM), the emulator becomes a black screen, then crashes, immediately after opening it.
Strangely enough, the game has worked in the past, but incredibly sparingly.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i7-8550U CPU @ 1.80GHz 2.00GHz
  • GPU: Intel UHD Graphics 620
  • Citra Version (found in title bar): Nightly 1083
  • Game: Pokemon Rising Ruby (Omega Ruby ROM hack)

Diagnostic Log
citra_log.txt (11.6 KB)

I found some issues in that log that need resolving:

  • Citra is currently utilizing open-source system files which may cause emulation to be less accurate, but not affect system stability.

Update your GPU drivers, btw enable ‘Enable Hardware Renderer’.

(was forced off original account because i mentioned r0ms and was instabanned before i could even get help)
I did that, and it did absolutely jack squat
citra_log.txt (14.5 KB)

I found some issues in that log that need resolving:

  • Citra is currently utilizing open-source system files which may cause emulation to be less accurate, but not affect system stability.

also pls forgive for hopping onto another account, i have no idea what’s going on or what the problem is and i just wanna play some pokemon

You must respect and follow the community rules. btw you need to download and install the latest driver for your GPU from the manufacturer website.

Edit: I tried different graphics settings, none of them work. Here are the logs from those:
citra_log.txt (14.5 KB)
citra_log.txt (14.5 KB)

I found some issues in that log that need resolving:

  • Citra is currently utilizing open-source system files which may cause emulation to be less accurate, but not affect system stability.

just updated my driver, didn’t work

Are you sure you’ve created a new log after installing the latest driver, or log still says Nvidia driver 388.75 while the latest (currently) is 416.34. either way, maybe a citra update broke compatibility, try to find the previous version that worked for you, nightly builds.

remember that rom hacks aren’t officially supported.

citra_log.txt (14.5 KB)
new log same problems

I found some issues in that log that need resolving:

  • Citra is currently utilizing open-source system files which may cause emulation to be less accurate, but not affect system stability.

The game worked for me (eventually) with 1082, but I reinstalled that one and it isn’t working again, even on the same settings
Edit: somehow it worked with accurate geometry the second time??? but my save data is gone… ah whatever it works now thanks

wait a minute wtf my computer went to sleep, my citra window just rando closed, and… it stopped working again? i’m so confused

???
citra_log.txt (14.2 KB)
:visible confusion:

I found some issues in that log that need resolving:

  • Citra is currently utilizing open-source system files which may cause emulation to be less accurate, but not affect system stability.

I found some issues in that log that need resolving:

  • Citra is currently utilizing open-source system files which may cause emulation to be less accurate, but not affect system stability.

Looks like your drivers are from Microsoft and not Nvidia, source: https://forums.geforce.com/default/topic/1039885/geforce-drivers/drivers-causing-restarts-or-gpu-problem-/post/5303135/#5303135

Download from Nvidia’s website: https://www.nvidia.com/Download/index.aspx
or through GeForce Experience.

1 Like