Pokémon shuffle FPS problem

Hi guys, i have a problem with pokémon shuffle, FPS seems to be locked at 35 for some reason, is there any way to unlock them?

Ryzen 5 3600
AMD 5700XT
Windows 10
citra_log.txt (4.0 KB)

The log file is incomplete. Make sure you follow the steps carefully:

  1. Open Citra, then go to File>Open Citra Folder (Citra>Open Citra Folder if on MacOS) and open up the log folder. Now keep that open in the background.
  2. Launch your game and encounter the problem; crash/slowdown/glitch and close Citra if it doesn’t do so by itself. Do not restart Citra as that will wipe the log of important information!
  3. Now upload the log file in this chat.

Okay, sorry for the inconvenience, i’ll upload the right log!
citra_log.txt (29.2 KB)

System Information for Support

Client Version                                Nightly 1719 HEAD-dfd7926
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 3600 6-Core Processor               | AVX2 | FMA
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon RX 5700 XT
GPU Driver Version                            21.8.1 27.20.22023.1004
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • Please enable the Vsync option if you are experiencing screen tearing.
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

You should disable Dump Textures in Emulation>Configuration>Graphics → This option is only useful for those that are interested in creating their own custom textures.
You may also want to delete all the textures it’s dumped so far: Go to File>Open Citra Folder, then open up the dump folder and delete the textures folder found here (this will delete all dumped textures for all of your games).

Thanks for the reply, but i had a fresh Citra installation so i deleted basically everything. I think that the problem is just the fact that i have an AMD graphic card at this point, a bit frustrating, this was the same problem (kinda) i had with Yuzu, but they improved AMD graphic cards performances a LOT, so most of my problems were solved, thanks to the improved stability of the Vulkan API which is not present on Citra rn unfortunately…

I’m not sure what you mean by this. The log file you uploaded shows that your settings were anything but “fresh”. Unless you mean that that’s what you did afterwards. There’s a couple more things that we could do to improve performance (even with your AMD GPU), but I’d need you to work with me.

Please upload another log file so I know what your settings are.

Oh sorry, i didn’t make myself clear, i deleted Citra after i uploaded the log, i meant that by a fresh installation, as i wanted to try Citra with stock settings.
citra_log.txt (22.6 KB)

System Information for Support

Client Version                                Nightly 1721 HEAD-89410c1
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 3600 6-Core Processor               | AVX2 | FMA
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon RX 5700 XT
GPU Driver Version                            21.8.1 27.20.22023.1004
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • Please enable the Vsync option if you are experiencing screen tearing.
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

Citra doesn’t actually uninstall the user folders when it uninstalls the rest of the program. Meaning that the user configuration and save files remain. That’s why your log file still shows your old settings.

In any case, let’s solve that for now: Go to Emulation>Configuration>General and select Reset All Settings here.
Start Citra back up again and go to Emulation>Configuration>Graphics>Advanced Tab and turn off Hardware Shaders here (this sometimes boosts performance on AMD GPUs).
Now try your game and see if the performance issues remain.

Wow! It fixed the problem, now FPS are stable at 60. Thank you so much for your help

1 Like