Pokemon SMD crashes during the first cutscene

Pokemon SMD crashes during the first cutscene (when deoxys flies toward the earth and meet rayquaza).
Referring to this topic : Workaround: Pokemon Super Mystery Dungeon crash locations ( number 1 ) said that this issue has been fixed and no workaround needed, but I’m still having this problem.

System Information

  • Operating System: Windows 10 x64 Version 1803
  • CPU: Intel Core i5-8250U
  • GPU: Intel UHD Graphics 620 & Nvidia GeForce MX150 4GB
  • Citra Version (found in title bar): Nightly 1145
  • Game: Pokemon Super Mystery Dungeon
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (29.8 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Download and install the latest driver for your GPU from the manufacturer’s (nvidia) website.
if the update doesn’t work disable ‘Enable Hardware Shader’ before launching the game.

Disabling hardware shader as mentioned in Workaround: Pokemon Super Mystery Dungeon crash locations fixed this problem. But I didn’t expect to run the game at 4-5 fps using the software renderer.
Already installed the latest driver for my GPU (both intel and nvidia), still facing the same issue.

Disabling ‘Enable Hardware Shader’ doesn’t mean that it won’t use the GPU for rendering, only by disabling ‘Enable Hardware Renderer’ citra will use its software renderer. try using your intel iGPU instead of the nvidia, it may run better.

Thanks for the solution, but it still doesn’t work. I’ve tried running it on intel integrated GPU ( with hardware shader disabled ) and the issue still presists. Also tried with my nvidia GPU and it produced the same results.
As for now, the only way that I can pass the cutscene is by disabling the hardware renderer which causing significant performance reduction and makes the game unplayable ( I only get 3-4 fps with the software renderer).

use the iGPU and upload your log again.

citra_log.txt (29.8 KB)
Using Intel UHD Graphics 620 with hardware shader disabled

I did not find anything wrong in your log file. Please wait for a moderator to assist.

There is a driver update for your intel GPU on intel’s website. download and install it.

I’ve already had the latest compatible driver installed for my GPU. The latest version on intel’s website is not compatible with mine.

for proper emulation the latest drivers are necessary, or at least not too old drivers.
you may have to try something like this (ignore the driver install instructions):

it seems that the latest update for citra canary(1118) fixes some issues with SMD, try it out.

Its now fixed (again) in canary 1121.
Thanks for the help, really appreciate it.

fyi, playing on Nightly 1038 build ( I had this one long time ago, just re opened after a while ),
works fine, but if updating to newest version it crashes lol, prob came with later updates only. ( at least among nightly builds, according to above comments here )

i don’t know if this fix got merged to nightly, try the latest canary.

nightly’s last build still broken, didnt install canary and im fine with this old build that works fine x)

When I Start Playing Pokemon, It Literally Just FPS Is 0.0, It’s Black Scene I See, Can You Help Me To How To Fix This Issue?

You are on citra Android which is only in development stages… It is not yet too optimized for playing every game… Wait for it to be fixed…