Pokemon Sun no longer loads after the update from a few hours ago

#1

Issue:
Running Pokemon Sun just fine on citra nightly about 10 hours ago. Then a few hours ago I received a notice for a citra update, updated my citra, and from then on the game refused to load.

System Information

  • Operating System:
  • CPU: Intel CORE i7
  • GPU: Nvidia 960M
  • Citra Version (found in title bar): Citra Nightly 1224
  • Game: Pokemon Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

citra_log.txt (21.8 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

#2

System Information for Support

Client Version                                Nightly 1224 HEAD-6f6bfd4
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 960M/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
#3

I assume Accurate Multiplication is under Citra Configuration -> Graphics -> Renderer -> Enable Hardware Shader -> Accurate Multiplication?

If it is, I tried running the game with it enabled and it’s still the same issue.

#4

Looks like either your ROM or Update got corrupted, redump them and try playing it again.

#5

Sorry, what do you mean by redump them? Reinstall them?

Edit: so this isn’t the first time this happened either. Happened twice before this and the only way was to reinstall everything as well as delete my settings and saves. I really don’t want to have to do that again.

#6

Do you have CPU JIT on? Its under Configure -> Debug.

#7

Yes, I do. But it’s checked and grayed out at the same time.

#8

Currently working for me after updating it about an hour ago. Tested on 2 different machines.