Pokemon Super Mystery Dungeon R button doesn't work

Issue:

I’m playing Pokemon Super Mystery Dungeon but I can’t skip the Watchog’s tutorial, where he teaches how to do the alliance attack, he tells me to press R lightly, I do it but he tells that I do it wrong, I don’t understand why it doesn’t work. I play with a Xbox Controller, I tried to press the R button with the keyboard, with Citra Canary, Citra Nightly, Citra Android but nothing works. Could someone help me please ? Sorry if my english is bad, I’m not a native english speaker.

System Information

  • Operating System: Windows 10.0.19044 Build 19044
  • CPU: 11th Gen Intel(R) Core™ i5-11400H @ 2.70GHz 2.69 GHz
  • GPU: NVIDIA GeForce RTX 3050
  • Citra Version (found in title bar): Citra Canary 2199
  • Game: Pokemon Super Mystery Dungeon
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

Haven’t played the game myself, but maybe they’re referring to how quickly you’re pressing the button? As in, a small tap?
The 3DS R button isn’t a trigger after all, it’s just a button. You either press it or you don’t. There’s no fine control there.

Thank you for trying to help me, I resolved the issue with Citra Android, I pushed the virtual R button and it worked.