Pokémon Sword failed fishing issue

I found really weird issue in Pokémon Sword during fishing. Fishing works OK when I press A button in time. I’ll get the battle and everything’s alright. However, when I fail to press the button, the game sort of freeze, though it’s not an actual freeze, since I still see animations of the surrounding, but no message and the only way out is to quit the game. This happens on the mainline Yuzu 455 and only with multicore support is enabled. With multicore disabled I normally get the message that I reeled too slow and can play further. Here’s the log from when that bug happened.
yuzu_log.txt (6.9 KB)

System Information for Support

Client Version                                yuzu 245 HEAD-mainline-636-2030-gb4cdaa755
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7300HQ CPU @ 2.50GHz
Graphics API                                  OpenGL 4.6.0
Graphics Renderer                             GeForce GTX 1050/PCIe/SSE2
GPU Driver Version                            445.87
Docked Mode                                   [ ]
Use Async GPU                                 [ ]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

Here’s some issues I found with your log that might help.

  • Enabling Async GPU emulation is recommended as it can improve the performance of many games.

Now, that’s weird. I do have the Aync GPU enabled, I can’t even disable it in my settings, so, how come it’s not enabled in the log?

OK, at least I got on to the issue of Async GPU. Obviously, it can’t be changed if multicore is enabled, but somehow, it was disabled for me, so, I disabled multicore, then disabled Async GPU, then enabled it again and enabled multicore again. That did the trick and now it shows as enabled in the log. Hopefully, it’ll stay that way. But that seems to have no effect on the bug above, so, here’s new log of that bug with Async GPU enabled.
yuzu_log.txt (1.0 MB)

Does this happen with multicore disabled?
I would keep multicore disable in a 2 modules FX, you can choke that CPU with multicore.

As I wrote, with multicore disabled everything works as intended. However, if I turn multicore off the game is so slow, that it’s practically unplayable :frowning: It’s no big deal as I usually am quick enough to press the button (and the vibrations that you, thankfully, applied recently, helped immensely with that), so, I guess I’ll just have to prepare for the occasional freeze in those rare cases I fail with my fishing. It’s the price for being able to even play the game on my crappy old PC. I just have to get into habit to save every time I try fishing, which is no big deal anyway :wink:

Yeah, I really recommend you to upgrade. Even a cheap quad core Ryzen will be several times faster than your current CPU.

Yeah, I have upgrade planned, but right now, my financial situation will not allow me that, so so, it’ll have to wait for spring :frowning:

But I did one thing I could afford right now and got the Early Access to see if that will have any effect, which I did not really expected, and also to support you guys, since you really deserve it. I couldn’t believe it, but my FPS increased significantly. Before, I could not get over 20 during the intro and during gameplay, my average FPS was 7 in outside areas. Now, I’ve got full 30 FPS in intro and 12-17 FPS outside. So, I’ve tried fishing and most of the time, I’ve got the message that I reeled too slow, though there were two of three cases when it frozen again. Not sure what it affects, though. But then, it gets even weirder, since I also tried the mainline (now version 459) and the FPS there was also as high as in the Early Access and the fishing also worked there during my testing. I don’t know what happened here, but I am glad for the FPS increase. Hope it will prevail, though and it’s not just some fluke.

That means the new scheduler fixed FX CPUs, great to know!