Pokemon sword freezing after battles

Which one are you using early access or mainline build?
Are playing in opengl mode or vulkan mode?
If it’s and you are having they switching to vulkan and it will be better.

I got good performance like that.

Early acess and OpenGL. I tried with Vulkan, and it seems to work without crashing. With my potato pc it barely gives 10 fps whereas OpenGL gives a playable 20+. Thanks for replying

Update: Vulcan is also crashing :cold_sweat:

i played the full game perfectly with mainline version with opengl…

Now the game isnt even opening. It shows a black screen, but theyuzu_log.txt (329.4 KB) sound works fine.

System Information for Support

Client Version                                yuzu Early Access 626 HEAD-d35fabb50
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz
Graphics API                                  OpenGL 4.3.0
Graphics Renderer                             Intel(R) UHD Graphics 620
GPU Driver Version                  
Docked Mode                                   [ ]
Use Async GPU                                 [ ]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

Here’s some issues I found with your log that might help.

  • Enabling Async GPU emulation is recommended as it can improve the performance of many games.

try using mainline version… if it works…

it isnt working on any version at all now, mainline and ea both. the sound plays and i can hear the game play but the screen is entirely black

try enabling AsynchronousGpuEmulation in emulation→configure→graphics

thanks a lot its working again now. the crashes are still happening though :cry:

I have the same issue like you do, and nothing about the settings or something, its a bug that has been in Yuzu since multicore has been implemented. Hopefully devs will fix it soon. It has been months already.

1 Like

@hugoduartee can you give your logfile

Yea. I tried on an older version of Ea (546) with Multi-core, and it works but with a lower framerate. It still freezes and crashes, but way less frequently.

I would stick with the current version, in any cases the freezing issue is still there. but also I have a feeling that is a cache problem too. I have noticed that I managed to play from start with 0 freeze, but once I start to reach the Route 4 and so on things start to look a bit more complicated. And with multicore when the game freezes check in task manager if the CPU is too high. if yes I believe is something related to multicore. so these two issues, cache and multicore should be fixed at some point.

1 Like

I have posted the issue before with Log file.

1 Like

Yea, same here. It was smooth until the second time you battled hop, then it started freezing up. Cpu usage randomly does shoot up, and yuzu itself crashes, but whenever the game freezes the cpu seems to be stable. I think it’s a cache problem like you said.

Got a similar problem. The game freezes when I click the Bag during battles. :pensive:

1 Like

it was fixed in a later yuzu version for me

Did you solve this ? I have the same problem

uncheck use fast gpu time in graphics tab