Pokemon Sword freezing on load

Hi guys!

Long time fan, first time writing in :slight_smile:

I’ve been running Pokemon Sword quite successfully on Yuzu since before Multicore was in even the Early Access builds. I’ve got the Isle of Armor DLC, captured Slowpoke and boarded the train. When I first did this, it froze before I could get to the station on Isle of Armor, but a restart fixed that issue. I exited the station, battled the trainer (leaving the name out to avoid spoilers) and found the dude missing a lot of Pokemon (again leaving this ambiguous to avoid spoilers). Since that encounter I’ve not been able to play the game. It freezes every single time on load and I can’t do anything about it. It did this before a few times, but through persistence I was able to get it working after restarting it multiple times.

What happens is the game loads, the world appears but the Pokeball loading indicator doesn’t disappear completely as the game has frozen. I’ve got an AMD CPU and AMD graphics card (don’t hate me). OpenGL works but the character models look really wacky, Vulkan works best for me. But I was able to play with either API.

Attached is my logs with both Vulkan and OpenGL. The OpenGL one actually crashed Yuzu when I selected to stop emulation.yuzu_log OpenGL.txt (105.8 KB) yuzu_log Vulkan.txt (168.4 KB)

Any ideas guys? This happens on both the mainline build and latest Early Access builds. I’m at a loss, I just want to play :sob:

Thanks in advance for your help!

Sorry forgot to attach these to the first post. I’d also like to add that I’m quite technically minded at troubleshooting so have tried various things such as switching Multicore off, using and not using ASYNC, deleting the Shader Cache and capping/uncapping the framerate, not using disk shader cache and a combination of all these things. Nothing makes a difference to it working, just slows it down haha.

I’ve increased the size of my Pagefile to 20,480MB (20GB) and updated my graphics card drivers to the very latest (released only a few days ago!). Still the same problem. Should I try uninstalling and reinstalling the DLC?

Can you try with a bigger page file? 25000mb for example.

You got in there just before me haha. I’ve extended it to 20,480MB. It was working perfectly fine with the original size so I don’t think extending it any further will help?

It helps in some cases, but if you report no change, then it is something else.

Cheers mate. Update: I’ve set the pagefile minimum to 1.5x my RAM, and the max to 4x my RAM (which is the max I can set). Restarted, closed all other applications as normal and still freezing when it loads.

Tried uninstalling and reinstalling everything. Started a new game, verified everything worked… Then restored my save and it freezes exactly the same. Any other ideas? :smiley:

Did you use any sort of save editor?

Yep, PKHeX at the very start of the game, just after I got my Pokemon. Played through without issue since then.

Depending of the version of PKHeX this can happen. Older versions introduced trash in the save file, and you only notice it once you reach the DLC.

Well that’s a bugger. I haven’t been able to unfreeze it since I got stuck in the spot its in now. Previously I was able to unfreeze it by resetting it and crossing my fingers. But whenever I approached the dojo it’d freeze. Assuming there was a cutscene trigger there that Yuzu didn’t like.

I’m guessing I have 2 options:

  1. Wait for Yuzu to be updated further and it may overcome the glitch in a future update
  2. Play through the game again but use the latest PKHeX so no junk is injected into the file, and cross my fingers?

Cheers!

Option 2 is the only one that will solve this, as option 1 is unrelated to what PkHex does to the save.

I’ll keep the old save and update if it works again magically in 3 months or so. Cheers for the help.

1 Like

I hope this helps you
I used yuzu mainline 41 and it loaded up so I opened the map and fast traveled back to the main part of the game

I am having the same problem game freezed when dojo came in sight before i saved game. Every time i reset it freezes and i am unable to even move my character
I have tried all different setting i.e changing api and shader caches but still i am unable to play it. Plz help me

1 Like

If disabling multicore is not enough, make sure you have any and all mods disabled.

I dont play with mods. Plz help me

Its not working with multicore disabled. My game shows - 0 fps, nan frame rate

Can you post a log file?

if you have saved in the Isle of Armor, i have the same problem, amd user

Hey friend - these are my log files
Yuzu EA 1171- earlyaccess1171yuzu_log.txt (167.3 KB)

Yuzu mainline 459 - mainline 459yuzu_log.txt (165.6 KB)

And mainline was earlier showing compatibility - okay
But as it updated to 459- its showing compatibility - bad

But early access 1171 still showing okay