Pokemon Sword having low fps now, when it didn't had before

Sometime ago (in september), i got a new pc which is really good, here are the specs:
CPU: AMD Ryzen 7 4800H with Radeon Graphics 2.90 GHz
GPU: Geforce GTX 1650 TI (also have an iGPU - [AMD Radeon RX Vega 7])
RAM: 16GB 3200MHz
And when i got it, i started playing Pokemon Sword and got some awesome preformance. The game was running smoothly at 30fps. But now, i came back to the game and the preformance was horrible, i was having 15fps-ish and it became unplayable! I tried a lot of different combinations of configurations and nothing worked! My drivers are up to date. Vulcan just made things worse and im out of options. plz help
Here’s the log: https://mega.nz/file/Cs8XlCaL#BZnWNErJWeeCkJ4BCTejQEwpsesPJ9bU-9hfCajF5Wc

Btw… is age of calamity still unplayable? like, i tried it and it was horrible, with black screens and stuff

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

https://mega.nz/file/Cs8XlCaL#BZnWNErJWeeCkJ4BCTejQEwpsesPJ9bU-9hfCajF5Wc

Set GPU accuracy to High, it’s in Emulation > Configure > Graphics > Advanced tab.

1 Like