Pokemon Sword - Isle of armor, Instant Freeze only in new Yuzu builds

I have a problem that is very strange , when trying to run Pokemon Sword and enter the DLC area isle of armor the game freezes instantly and only the background music remains, this Error only runs in the most recent versions of Yuzu, since in old ones like Yuzu 290 It works perfectly, I find it strange that if I works in old builds, and not in new ones, that’s why it leads me to suspect that maybe it is something of the new builds

-I5 8400 - RX 570 8gb - 16gb ram ddr4.

I already try change opengl/vulkan, dissable async, multicore, set pagefile to 24GB. and i dont have any mod installed.

also y try the old Amd driver(20.4.2) and the new one (20.8.3)

I do not know what else to do

yuzu_log.txt

1 Like

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

This could be related to the Multicore changes. We’re investigating it.
Can you upload your save file for testing?

Of course

http://www.mediafire.com/file/q63q813l4y1auw9/file

if necessary I can upload a video showing the problem

Yeah I can reproduce it from my end. Have you used a save editor?.

yes, i use save editor to do some testing

Then that’s the cause, older versions of save editors introduced garbage data in sections that the DLC later used. I’m not sure what is the fix for this, most likely you will need to start fresh, and edit with a more recent version of the program.

do you mean starting a new game or installing yuzu from 0? because I sent the save to a partner and it worked for him

well I have a few more clues about what is happening

my partner try to play in vulkan in the same place where im in and get the same insta freeze

the differense is he have a gtx 1080 and i have a rx570,
he can play normaly using opengl but i can’t, i still having the same freeze

I guess that’s where the problem must be.

On the Rx570, the Crash in Vulkan is caused by a Problem in Yuzu and the Crash using OpenGL is the fault of the RX graphic cards.

See if your friend can save later and load fine.

Yes, he can save and load game without problems.

Just in case, this problem continues to occur in the latest versions of yuzu

Does this happen with a fresh save without using an editor?

Yes, this happen on a fresh new save too

same problem with ryzen 5 2600 and amd rx580 8GB, i’ve given my save file to a Nvidia user and on his pc all worked
i’ve never used any sort of editor btw

Another update: Using Yuzu 417 In the new DLC “Crown tundra” you can go to the new dlc, and play a random short time(from 5 seconds to 4 minutes) and the game freeze in 0 fps. (Isle of armor still unplayable)

Again. The most stable version i found to play pokemon is Yuzu 290, Is a little slow yea, but it have 0 crashes of any type. and all works nice

1 Like

@SylveonTM thanks for shearing your findings, a little slower is better than nothing, I don’t have this problem with the new versions, Nvidia user.

I am having a similar problem in crown of tundra. To progress in the history we need to battle in the Max raid adventures, but when you win the raid it instantly freeze, it doesn’t matter if you try to catch the pokemon or not.

I have the same issues that SylveonTM. Just an addendum, most of the sea of Isle of Armor is playable, I have caught the Level 80 wailord and many others sea Pokémon. However, the inland and near sea is unplayable, always freeze (from 5 seconds to 2 minutes).

My PC has a Ryzen 5 1600 and a Rx550.

DarkQueen, in the Max raid adventures you have that disable multicore emulation. I have finished several adventures raids with the option disabled. With it enabled, the game always freeze.