Pokemon sword runs awesome on vulkan but terrible on opengl

well, good day to all of you, i write this because im playing pokemon sword on yuzu but i get lots of crashes using vulkan, with opengl it seems like i get no crashes but it runs terrible, so, i dont know what to do, i would like some help

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Can you post me a log file after one of the Vulkan crashes? Getting Log Files - yuzu

1 Like

yuzu_log.txt.old.txt (945 Bytes)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

yuzu_log.txt (2.1 MB)

Set CPU accuracy to auto, disable asynchronous shaders, and make sure you’re running the latest GPU driver on the integrated Intel GPU: Intel® Graphics – Windows* DCH Drivers

1 Like

didnt work, i suppose its because ive to update the dch drivers, idk how to do that, il fix that and then il tell you if it worked or not

ok i did but now the crashes are more often

Try with multicore disabled, Pokémon is known to have stability issues on yuzu with 4 thread CPUs. We’re working to solve this.

1 Like

i tried that and now the game takes forever to load up, i suppose il just wait until you fix that, thanks for your time, have a great day

1 Like

Hello, I had the same problem.
I don’t really know if this is placebo or if it actually worked, but what I did was change the CPU Affinity of Yuzu so it only uses two cores out of four that my cpu has. I use a program called Process Lasso that lets you make that kind of changes permanent, as long as Process Lasso is up and running.


Kh5dYKCS1n
I hope this helps with your problem.

PD: I did this with a Ryzen 3 1200 and the performance hit of using 2 out of 4 cores is really low, it is completely playable at full speed.

2 Likes

thanks for your reply, il check if that works for me

1 Like

well, i tried it with lasso, but still crashing, and sometimes the crash is weird because the game says 0 fps and then blue screen, i checked the log and its full of this error HW.Memory core\memory.cpp:operator ():498: Unmapped Read32 @ 0x00000000003D295C

Changing the CPU Affinity was not the only thing I did, I also added a page file of almost 26 GB, and have the GPU on normal accuracy level. Those 3 things made my game not crash anymore. I have to point out that I tried making it use 3 out of 4 cores and it would crash anyways, it only stopped crashing when I put it to use only 2.

1 Like

What’s a 26 gb page?

Page file.
I don’t know how to explain it exactly in english, but basically, it starts using it as RAM when your system runs out of the actual RAM. This helps with the crashes because Vulkan has memory leaks.
To set a page file you have to write ‘advanced’ in Windows Search and open ‘View advanced system settings’.


Then you have to go to Performance settings.
image
And go to the advanced tab.

In the virtual memory section, you click on change and uncheck the ‘automatically manage paging file size for all drives’ option. Then select a drive and click on Custom Size.

On the initial size and maximum size, personally I put the same values, but basically, the value you input in here is the amount of space of your drive that the system is going to use as virtual memory.
I don’t want to recommend a particular value to write there, but with 24,576 MB (24 GB) it is fine for me. After entering the amount of virtual memory that you want, don’t forget to hit 'Set’
image
After that, restart your computer and give it a try. I hope this helps.

1 Like

Thanks, il try that and i Spanish is my main language too, thanks for your time and answers

1 Like

You’re welcome, and no problem, happy to help!

1 Like