Pokemon Ultra Moon crash with hardware shader+accurate multiplication

Issue:
Hello,

Pokemon Ultra Moon crashes during:

  1. Kukui’s introduction
  2. Start of any battle
  3. Zone transition

I can get around these crashes by disabling hardware shader but the game runs at 40-60% speed which is not very enjoyable. With hardware shader and accurate multiplication it runs smoothly even at 150-200% speed and higher resolutions except during the scenarios mentioned above. Is there anything reasonable I can do to play at least at native (400*400) res and 100% speed?

Any help is appreciated!

System Information

  • Operating System: Windows 10 Pro
  • CPU: Intel® Core™ i5-8400 CPU @ 2.80GHz
  • GPU: GeForce GT 730
  • Citra Version (found in title bar): Citra Canary 1773
  • Game: Pokemon Ultra Moon
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (127.3 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1773 HEAD-d299355
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-8400 CPU @ 2.80GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics 630
GPU Driver Version                            23.20.16.4974
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Since you have a desktop computer, i5-8400 is a desktop CPU, you need to connect your monitor(s) to the graphics card and not the motherboard. Take a look at the back of your computer and replug the HDMI/DVI/DisplayPort cable (whatever you are using) into the graphics card.

Yeah, sorry I noticed late that the application was using my integrated instead of my dedicated gpu. I already changed it but the problem persist. I found a workaround solution by using an old citra client : https://www.youtube.com/watch?v=bMZKMgzG2Eo

I would still like to use the most current one if you have any suggestions!

Upload a new log on latest Citra with Nvidia instead.

Turns out even after I changed my Program Settings on Nvidia Control Panel, Citra was still using the integrated GPU instead of the dedicated, so I went ahead and changed my Global Settings to use my dedicated GPU for OpenGL and that did it. Now it runs smooth at 4x native res and no crashes at transitions nor battles!

Thanks for pointing me in the right direction :slight_smile:

1 Like