Pokemon Ultra Sun an other games never lock into 100%

In every single game that I play with Citra, it reaches 90-100%, and the framerate is always around 25-30 fps. With severe slowdowns in some parts.
Coniderig my PC, I was wondering if there’s something in my configuration that prevents it from staying in 100%. Thanks for your time.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5-72000U 2.5GHz with Turbo Boost up to 3.1GHz
  • GPU: NVIDIA GeForce 940MX with 2GB Dedicated VRAM
  • Citra Version (found in title bar): Citra Nightly 1189
  • Game: Pokémon Ultra Sun (and other games)
  • Screenshot of Issue (include the full Citra window including titlebar):

citra_log.txt (65.3 KB)

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:

System Information for Support

Client Version                                Nightly 1189 HEAD-1f31f23
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce 940MX/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Try the following:

also check this:

and update your GPU drivers, download the latest from nvidia’s website.

Oh god, thank you so much. I would add this:
Change the battery preferences from economy to performance in Intel Graphics Configurations.

Overall it seems like the battery settings were the ones causing this under-performance issue.

Thanks so much!

1 Like