Pokemon ultra sun and moon shaders

hello, i was having problems with the textures flickering so i turned off hardware shaders and that seemed to solve the problem exept now the game will not run at 100% speed even if i turn the resolution down to 240p can someone help me?

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Same issue here. It’s actually been an issue that has been happening since I first started using Citra quite some time ago, and persists in both Nightly and Canary regardless of version. Unfortunately, there’s nothing to do about it and you have to pick your poison.

From what I gather, enabling “Hardware Shaders” uses your GPU in addition to your CPU to run the emulator, while disabling it uses your CPU only. If you have a strong, single-core CPU then you can keep them disabled and get decent speed, but if you have a bad CPU, or even a powerful, modern CPU with multiple cores, having Hardware Shaders enabled is pretty much mandatory. This means that if disabling the shaders gives you bad FPS, there’s nothing that you can really do to improve it, either you deal with the flickering in exchange for the higher resolution or you play it on an actual 3DS.

The funny thing is that I was able to run Hardware Shaders on with “Accurate Multiplication” enabled and it worked flawlessly with absolutely no flickering, then my old GPU (2GB GT 730 MSI) died and I upgraded to a GT 1030 EVGA and the flickering started happening unless I turn hardware shaders off. I’m not sure if the fact the 730 MSI was using older Nvidia drivers had anything to do with this or not.

EDIT: Decided to test older versions and found out that Citra Canary 1058 and earlier versions actually do not have the texture flickering with Hardware Shaders enabled. I haven’t tested the Nightly ones, but it you could try older versions to see how it goes, as far as I know the newer versions of Citra haven’t really added anything to Ultra Sun/Moon.

they need to update it to where the shaders dont completely make sun and moon unplayable its not like i have a bad cpu i have a 5820k but it doesent want to run at full speed no matter what i do

First off, they don’t “need” to do anything. I don’t mean to come off as rude, but it’s not like this is their job. Citra is developed as a hobby by volunteers, not paid programmers.

Second, the flickering shaders do not make the game unplayable. Annoying to look at, yes, but it’s perfectly playable from start to finish.

Third, Citra doesn’t handle multi-core CPUs all that well. In fact, it runs better on older single-core CPUs because the one core they do have runs at full speed as opposed to modern CPUs where each core runs at a lower speed and, together, achieve the CPU’s maximum processing speed. Hardware shaders improve the game speed because they use your GPU to aid in processing in addition to your CPU, but this method causes glitches in some games.

Finally, if the flickering textures bother you so much then just download Citra Canary 1058 and play the game through that. I tested it and the textures do not flicker whatsoever even with Hardware shaders on, so it should solve your problem and let you run the game at 100% speed.

Can you confirm something for me? Test the following builds:

And tell me if the flickering is there on 1114 but not on 1113.

Sorry, I know this is late and might not be needed anymore but life has been hell lately.

Tested both builds, Nightly 1113 works fine without flickering with Hardware Shaders and Accurate Multiplication enabled.

Nightly 1114 has the texture flickering no matter what combination of settings I use. Only turning Hardware Shaders off removes the flickering.

Hi everyone, just posting this reply to mention that this issue appears to be fixed in the (as of the time of me writing this comment) current canary version (Canary 1344). Game seems to work flawlessly with hardware shaders on with no texture flickering whatsoever.

Hi how do you turn off the shaders ?

Hardware Shader settings is in the Advanced graphics options in Citra configuration.