Pokemon Ultra Sun Black Screen Help?

Issue:
I don’t know what’s wrong but the screen is black when booting the game but the sound is still playing. I have a ok computer I checked on all of my devices it’s all up to date.

Citra log: https://www.dropbox.com/s/03fx7w93r50ecz7/citra_log.txt?dl=0

System Information

  • Operating System: Windows 10 Pro (64 bit)
  • CPU: Intel® Core™ i5-8400 CPU @ 2.80GHz 2.81GHz
  • GPU: Intel® UHD Graphics Family
  • Citra Version (found in title bar): Citra Nightly 1535
  • Game: Pokemon Ultra Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

You do not have a graphics card in that computer, just integrated graphics?

NVIDIA GeForce GTX 1060 6GB

Ok, since Citra is picking up your iGPU that means you need to replug your monitor so it’s connected to the graphics card and not the motherboard. Look at the back of your computer and fix that :stuck_out_tongue:

I re-plugged and everything but now I can’t open my Citra program. I tried re-installing (It doesn’t work),
I tried using manual install and it still doesn’t work

Hm, try do a clean install(check the box in the installer) with this driver: https://www.nvidia.com/en-us/drivers/results/157539/ the latest seems to be causing issues.

I already did and it seems like it’s the cause of the problem because it’s working fine before then.

Can you confirm you are on 442.50? (Open Nvidia Control Panel then click the Home icon):
image

Citra doesn’t open at all now? Unplug any controllers that you have connected to the computer if you have and try turn off antivirus temporarily.

I downloaded the NVIDIA CONTROL PANEL from Microsoft Store but then it says “Application is not compatible with installed NVIDIA Driver.” but I have NVIDIA GeForce Experience Version: 2.11.4.0. My Driver version is 368.81.

Nah, always get from Nvidia’s website directly.
https://www.nvidia.com/download/driverResults.aspx/157537/en-us

You also don’t really need GeForce Experience but that is up to you if you use ShadowPlay / fps counter. Download from the link above then check the “clean install” in the installer.

I downloaded it but Citra still doesn’t open.

If you replug the monitor back to the motherboard instead it works again? If yes that is very bizarre.

If you have the time try build Citra from source and run through Visual Studio so it can catch the crash. Follow these steps: https://github.com/citra-emu/citra/wiki/Building-for-Windows

There is one outdated image regarding cmake, just pick Visual Studio 16 2019 instead of Visual Studio 15 2017.

I cannot replicate this issue on an i7-3770K with GTX 1070 so I need your help.