Pokemon Ultra Sun - Citra running weirdly slowly

Issue:
Pokemon Ultra Sun runs pretty unreasonably slow, I haven’t tried any other games yet but it definitely doesn’t feel like I should be eating bricks like this in terms of performance, it is a laptop yes, but I’m pretty sure that much worse PC’s than what I have could probably run Ultra Sun at more than a max of 10 FPS, but maybe I’m just incorrect? Thanks in advance.
(there is maybe also a chance that only the beginning of the game lags? but I don’t think I have the brainpower necessary to go through the entire beginning while its stuttering so hard)

System Information

  • Operating System: Windows 10 64-bit

  • CPU: AMD Ryzen 5 4600H (2,459 on the single thread performance thingy)

  • GPU: NVIDIA RTX 2060 (mobile, aka laptop version)

  • Citra Version: Citra Nightly 1781

  • Game: Pokemon Ultra Sun

  • Screenshot of Issue:

citra_log.txt (11.5 KB)

Diagnostic Log

System Information for Support

Client Version                               Nightly 1781   HEAD-141471e
Operating System                             Windows 10 (10.0)
CPU                                          AMD Ryzen 5 4600H with Radeon Graphics          | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            NVIDIA GeForce RTX 2060/PCIe/SSE2
GPU Driver Version                           516.94
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [x]
System Region                                2
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • Please enable the Vsync option if you are experiencing screen tearing.
  • LLE Audio is designed for debugging purposes. Using this option will slow down your game. Try changing to HLE audio.

okay, nevermind, i am just stupid, LLE audio apparently destroyed my framerate by 60 fps, i am amazed at my own stupidity

Yea, whilst LLE is very accurate, it is extremely slow. Which is why its only use is for debugging purposes currently.