Pokemon Ultra Sun Crashes when Hardware Shader is on

#1

Issue:
While “Enable Hardware Shader” is on and both Multiplication and Geometry Shader are also on, Pokemon Ultra Sun runs at full speed even more than 100%. But at some dialogue scenes and every time I encounter a pokemon or a trainer it crashes and then it goes black screen. When I disable the later options, game runs at 60-65% speed. Is there any way to prevent the crashes? Also there’s no v-sync option anymore, how can I disable it in case it is on?

System Information

  • Operating System: Windows 10

  • CPU: Intel® Core™ i5-7200U CPU @ 2.50GHz

  • GPU: AMD Raden ™ R5 M330

  • Citra Version (found in title bar): Canary 1115

  • Game: Pokemon Ultra Suncitra_log.txt (120.8 KB)

  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

#2

I did not find anything wrong in your log file. Please wait for a moderator to assist.

#3

i think v-sync has been removed completely, either way its disabled according to your log.
also your log is showing that citra is using the intel iGPU, it may be preferable to use the AMD GPU for gaming (specially games that don’t like iGPU, like most pokemon games)
from support.ubi.com:

Switching to the dedicated AMD GPU

  • First, open Radeon Settings . One way to do that is right-clicking on an empty space on the desktop and choosing Radeon Settings from the menu.
  • Navigate to Preferences > Additional Settings > Power > Switchable Graphics Application Settings.
  • Select the game from the list of applications. If it is not in the list, click the Add Application button and select the *.exe-file of the game from the game’s installation directory. This adds the game to the list and you’ll be able to select it afterwards.
  • In the column Graphics Settings , assign the High Performance profile to the game.

Finally, apply your changes. Your game should now run with the dedicated AMD GPU.

1 Like
CITRA Nightly 1170 No shadow Good performance
#4

It worked. Thank you!