Pokemon Ultra Sun Crush When Hardware Shader Option is Enabled

Issue: I just discovered after long time playing, that when “hardware shader” and “accurate multiplication” options are enabled, this pokemon game runs in full speed, which I love, but every animated scene, every time a pokémon appears, the game crushes and the screen goes black.
So, normally I play this without those options enabled, but it runs at 50-60% of speed. I just want to play at higher speed…

System Information

  • Operating System: Windows 10
  • CPU: Intel® Core™i3-6100U CPU @2.30GHz (4 CPUs), ~2,3 GHz
    Ram 8192 mb
  • GPU: Intel® HD Graphics 520
  • Citra Version (found in title bar): Nightly 1695
  • Game: Pokemon Ultra Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (958.2 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

There are a bunch of things that I can see in your log file that ‘‘could’’ cause this issue. Let’s go over them one by one:


GL_VERSION: 3.3.0 - Build 23.20.16.4973
These drivers are severely out of date. To update them: Download win64_15.45.5174.zip (direct link) from Download Intel® Graphics Driver for Windows* [15.45]

Then follow this guide to install them: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

After installing that driver, you should be able to directly install the latest drivers available for your GPU: Download and install igfx_win10_100.9316.exe from Download Intel® Graphics - Windows® 10 DCH Drivers


Your CPU Clock Speed is currently set to 5%. Which is incredibly low and could most definitely cause a lot of freezing and crashing related issues as well as audio instabilities. Underclocking is also not at all useful in Pokemon Ultra Sun, if anything, overclocking slightly (125%) would be more benificial for reducing stutter.
Go to Emulation>Configuration>System and set the CPU Clock Speed back to 100%.


Your log file is showing:
[ 17.861402] Service.FS <Warning> core/file_sys/ncch_container.cpp:LoadOverrides:472: Loaded NCCH C:\Users\usuario\AppData\Roaming/Citra/nand/00000000000000000000000000000000/title/0004009b/00010202/content/00000000.app is tainted, application behavior may not be as expected! [ 17.861907] Service.FS <Warning> core/file_sys/ncch_container.cpp:LoadOverrides:472: Loaded NCCH C:\Users\usuario\AppData\Roaming/Citra/nand/00000000000000000000000000000000/title/0004009b/00010402/content/00000000.app is tainted, application behavior may not be as expected! [ 17.862399] Service.FS <Warning> core/file_sys/ncch_container.cpp:LoadOverrides:472: Loaded NCCH C:\Users\usuario\AppData\Roaming/Citra/nand/00000000000000000000000000000000/title/000400db/00010302/content/00000000.app is tainted, application behavior may not be as expected!
Which would indicate that you currently have a few corrupted nand files in your nand folder. It would therefore be a good idea to reset that nand folderL
Go to file>Open Citra Folder and then delete or rename the nand folder there. Either should have Citra create a new nand folder upon a relaunch.


Lastly, I can see that there is some sort of LayeredFS mod file being used in your game. Corrupted mod files can definitely cause this kind of problem as well. Disable any and all mods that you currently have enabled and restart Citra.

If you’re still experiencing the issue after going through all the steps, please upload another log file.

1 Like

I updated the drivers and it worked. Thank you so much! :smiling_face_with_three_hearts: :blush:

1 Like