Pokemon Ultra sun Freezes on same part

Issue:
Enter a description of your issue here, in full detail.

My game is always freezing when doing a battle against a ponyta in the storymode.

System Information

  • Operating System: Windows
  • CPU: Intel® Core™ i7-7500Y [email protected] 2.70GHz 290GHz 8GB RAM
  • GPU: Intel HD Graphics 620
  • Citra Version (found in title bar): 1629 nightly
  • Game: Ultra sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
<citra_log.txt (283.8 KB) >

System Information for Support

Client Version                                Nightly 1629 HEAD-1bb2057
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 620
GPU Driver Version                            26.20.100.6888
CPU JIT                                       [x]
Hardware Renderer                             [ ]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Still not working :confused:

Do you have discrete GPU like Nvidia or do you only have integrated graphics?

You can check in Device Manager under Display adapters.

No just the one intel gpu

GPU Driver Version: 26.20.100.6888

This driver is outdated, you need to update.

Download and install igfx_win10_100.8853.exe from: https://downloadcenter.intel.com/download/29957/Intel-Graphics-Windows-10-DCH-Drivers?product=95451
direct link: https://downloadmirror.intel.com/29957/a08/igfx_win10_100.8853.exe

If you cannot install 8853 right away, downgrade to 6373 first:

Download win64_25.20.100.6373.zip from https://downloadcenter.intel.com/download/28289/Intel-Graphics-Driver-for-Windows-10
direct link: https://downloadmirror.intel.com/28289/a08/win64_25.20.100.6373.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Also do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Turn on Disk Shader Cache
  5. Click on the Advanced tab and turn on Enable Hardware Renderer and Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.