Pokemon Ultra Sun_ Lagging when entering battle

Issue: My game will always lag when entering a battle ( both trainer and wild)
Right after the moment, the game enter the battle , the game will drop fps to 30% and get back to 100% after we are in the battle screen

System Information

  • Operating System: Windows 10
  • CPU: i5-7200U
  • GPU: NVDIA GeForce 940MX
  • Citra Version (found in title bar): Canary 1599
  • Game: Pokemon Ultra Sun
  • Screenshot of Issue (include the full Citra window including titlebar):


Diagnostic Log
citra_log.txt (371.9 KB)

I know that my laptop is not the strongest one ( a hand me down) but i did play Gen 6 with no issue. So I have no idea why it lags :(( . Thanks in advance for any help :slight_smile:

System Information for Support

Client Version                                Canary 1599 HEAD-b2ec35f
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

The log gets cleared each time you open Citra so make sure you do these steps to ensure it catches the issue:

  1. Open Citra then File->Open Citra Folder then log folder(keep this open in the background, do not close the folder).
  2. Start the game, reach the issue in-game then close Citra(don’t reopen or the log gets cleared so you have to do it again).
  3. Reupload the log here.

Oh ok thanks. Will do it after I get back from work.

System Information for Support

Client Version                                Canary 1600 HEAD-a648cbd
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce 940MX/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            391.25
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

Uhmm i updated the log. If it’s wrong do tell me so I can try again. Thanks in advance :slight_smile:

Ok, update the drivers to 442.59(follow the bot’s link above) and then we can see if we can tweak some settings.

Ok , downloading it right now. After we update what will we do ?

Hello. I am also having the same problem while launching pokemon sun while using citra. Its actually quite laggy. The laptop I am using is Acer A31555G5512. Can anyone please help?

:v uhmmm gonna comment another one to up the post

In addition, set Power management mode in Nvidia Control Panel to Prefer maximum performance. In Windows make sure you have set a high performance plan, if you can’t select one use the “Create power plan” on the left and select it there.

Citra emulation isn’t perfect though, there are cases where it isn’t smooth all the time even with an i9-9900K so :stuck_out_tongue:

Ok gonna try it and finish this post here :slight_smile: Thanks for your help.