Pokemon Ultra/Sun Moon - black screen and 0 fps

Issue:
When I run Ultra Moon it goes straight to a black screen showing 0 fps / no sound. The game ran fine with no issues approximately 2 weeks ago. I updated my GPU drivers in that time but rolled back to previous version with no success, and since re-updated to latest driver. A friend running the same GPU does not have this problem. I later tried patching Ultra Moon to 1.2 but rolled it back as well - really unsure if this messed something up. All other games (Pokemon Y, Fire Emblem Awakenings) continue to work with no issues. I’ve tried running old versions of Citra both nightly and canary, no luck.

System Information

  • Operating System: Windows 10 Home
  • CPU: Intel Core i7-6700HQ CPU @ 2.60GHz
  • GPU: GeForce GTX 960M
  • Citra Version (found in title bar): 1781
  • Game: Pokemon Ultra Moon
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
<https://community.citra-emu.org/t/how-to-ucitra_log.txt (13.6 KB) pload-the-log-file/296>

System Information for Support

Client Version                                Canary 1781 HEAD-d0c61b6
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 960M/PCIe/SSE2
GPU Driver Version                            446.14
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Try redump the game and the update using the guides below to make sure they are clean. Have at least 4GB free space on your Nintendo 3DS’s SD card:



I’ve re-dumped and same issue. I ran it today on my friend’s laptop who also has a GeForce 960M gpu no problem.

Could something have maybe messed up with Citra when I patched the rom and the issue is lingering elsewhere? When I uninstalled Citra and re-downloaded, and noticed all my settings and save files remain. I don’t have a technical background so I’m at a loss here.

This is probably why, does it work fine with an unedited version?

Yeah this is intentional, if do want to clear everything also delete the Citra folder in \AppData\Roaming folder

It does not work with or without the patch. When it worked a few weeks ago it was the unpatched file. I haven’t tried running it with a patch since re-dumping the rom this morning. My friend who ran this rom this morning did not patch it either.

Any chance a full clear of citra files and running on new dump will do anything?

you need to delete the citra folder in your roaming to full clear your citra(it will delete your save files as well as user data) to delete it press “windows+R” shortcut key and then type “%AppData%” and press ok and delete the citra folder there…

1 Like

It worked. I deleted Citra entirely from my computer and re-ran it. It was probably related to patching the rom - lesson learned.

Thanks everyone for your help.

1 Like

Hi, i’ve been encountering the same issue when trying to run Pokemon Ultra Sun. The game will run if I play an unpatched version. But only after I install update v1.2 the game will not work. I want to play with an updated version so i can transfer saves between my 3ds and citra, can anyone help me out with this?

This is more than likely a bad update dump. Please redump the update:

To dump DLC and Updates, use this guide Dumping Updates and DLCs - Citra and install the results through File -> Install CIA...