Pokemon Ultra sun /moon keeps freezing Citra Nightly 1553

Issue:
Pokemon Moon and Pokemon Ultra sun keeps freezing(video), with hardware shader and accurate multiplication enabled. I tried Disabling Hardware Shader and acc multipl option. It worked but game became unbearably slow. I went down a build from 1554 nightly to 1553 nightly, still same issue. This happened after the build 1554 update. Please help, and i dont want solutions where the game works at slow speeds

System Information

  • Operating System: Windows 10 Home
  • CPU: Intel®Core™i5-7200 [email protected] 2.50 GHz 2.70 GHz 8GB RAM
  • GPU: Intel® HD Graphics 620
  • Citra Version (found in title bar): 1553 Nightly and 1554 Nightly
  • Game: Pokemon Ultra Sun and Pokemon Moon
  • Screenshot of Issue (include the full Citra window including titlebar):

*LOG FILE
citra_log.txt (154.5 KB)

System Information for Support

Client Version                                Nightly 1553 HEAD-81a1e56
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 620
GPU Driver Version                            23.20.16.4973
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Open Nvidia Control Panel then in Manage 3D settings, set preferred GPU to Nvidia. While you are there set Power management mode to Prefer maximum performance.
If you have GeForce Experience installed, turn off Battery Boost as well:

Ohk so i messed up, somehow my nvidia graphics card is not being detected, so ur solution wont be useful

anything i can do with the intel gpu itself

System Information for Support

Client Version                                Nightly 1553 HEAD-81a1e56
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 620
GPU Driver Version                            23.20.16.4973
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

We should fix so you can use your 940MX.

Install the latest drivers first and pick “clean install” when you pick custom install.

https://www.nvidia.com/Download/driverResults.aspx/159888/en-us

image

It worked, thank you 3000 ! You’ve made my day !

1 Like