Pokemon Ultra Sun running on max 15 fps

Issue:
Enter a description of your issue here, in full detail.
In most sections of the game, i am getting little to no frames and its a little jittery.

System Information

  • Operating System: Mac OS 10.15.7
  • CPU: 2.5 GHz Dual-Core Intel Core i5
  • GPU: Intel HD Graphics 4000 1536 MB
  • Citra Version (found in title bar): Citra Nightly 1737
  • Game: Pokemon Ultra Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (100.2 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                               Nightly 1737   HEAD-28039d3
Operating System                             macOS 10.15
CPU                                          Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz | AVX
Graphics API                                 OpenGL 4.1
Graphics Renderer                            Intel HD Graphics 4000 OpenGL Engine
GPU Driver Version                           ?
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [ ]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

I was recommended to turn that off last time when i was having issues with the game, because a lot of the interface was missing otherwise

I think you should update your Citra to the latest one because for me it reaches 60 fps but mine is in Windows so maybe there is a difference between the Windows build and Mac Build

Ive been using citra for about 9 months now and never really had any problem until recently when i tried playing ultra sun, but i guess your solution is worth a shot

First off, don’t use save states to record your progress, or whilst troubleshooting. Second, re-enable Hardware Shaders. Though, with your hardware you might want to keep Accurate Multiplication disabled to prevent graphical issues from occurring. You can find both options in Citra>Preferences>Graphics>Advanced Tab.

What can i use instead of save states? Also enabling hardware shaders really didnt change much except for some minor graphical issues

In-game save files. Just load your game like you would on the 3DS.

Did you make sure that Accurate Multiplication is disabled?

Yes it is

Then there isn’t anything else we can do. Your hardware is very old and generally close to being unsupported.

Thanks for the help anyway

1 Like

I was playing later on and your solution seems to have improved the frames by a decent bit, thanks

Disabling frame advancing helped me increase it by 15 fps

I dont know where the option for that is