Pokémon Ultra Sun starts very slowly

My Pokémon Ultra Sun games starts very slowly. A black screen for at least 2 minutes before starting the game. My computer is relatively good and new.

System Information

  • Operating System: Windows 10 Pro
  • CPU: Intel Core i7-8700 CPU @ 3.20GH
  • GPU: 16 GB
  • Citra Version (found in title bar): Citra Canary 1539
  • Game: Pokémon Ultra Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

citra_log.txt (56.7 KB)

System Information for Support

Client Version                                Nightly 1402 HEAD-cd86c9b
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) UHD Graphics 630
OpenGL Version                                3.3.0
GPU Driver Version                  
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 2

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

The problem continues.

I updated my Citra Nightly yesterday and ran into the same problem. All games had worked perfectly before that. It’s such a pain now as I’m SR-ing for a wormhole legend. Maybe I should put it on hold until the problem gets solved (I hope it’ll soon be)

It’s a feature, which caches the shaders before launching, for smoother gameplay. It can be disabled in Emulation>Configure>Graphics>Use Disk Shader Cache.