Pokemon Ultra Sun - The SD Card couldnot be recognized

citra_log.txt (5.9 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

It still showing the SD card not recognized

citra_log.txt (4.0 KB) Fix this plzz…

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Open citra, go to File>Open Citra Folder. Then open the sdmc folder and create a folder called DCIM in there. Now go back in game and see if it allows you to progress past the poke finder.

Alternatively, you could download a manual build and put it in portable mode. You can do this by going to the citra-emu.org, going to download and then select “manual download”. Click on the icon of the latest version available for your OS. After downloading the file, extract it using winrar or 7zip and put it anywhere you want, except for in Appdata. Inside the unzipped folder you’ll find citra-qt.exe. To put citra in portable mode, simply create a folder called user in here. Now you can run citra-qt.exe to start citra and run your game. This Citra version should behave as if it has no data from your normal installation version of Citra. Reach the point in the game where the error occurs once more and see if this allows you to go past it.

Lastly, if you don’t have any game update installed, please try dumping and installing that in Citra.
To dump DLC and Updates, use this guide https://citra-emu.org/wiki/dumping-updates-and-dlcs/ and install the results through File -> Install CIA...

I’m having the same problem here this time it’s Alola Photo Club as this is a required story section. First time it worked fine but after I forgot to save the game and loaded my last save the feature stopped working and it goes straight to SD card not recognised. citra_log.txt (11.8 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Same one but slightly updated now.citra_log.txt (125.2 KB)

System Information for Support

Client Version                                Nightly 1623 HEAD-a576eb6
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-10210U CPU @ 1.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics
GPU Driver Version                            26.20.100.6911
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

Did you try the “fix” I said earlier? If not, please try that first. Also, disable cheats and restart citra.

Let me explain exactly how this all happened:
First of all, on my Pokemon Y save file, the camera feature (you know, for taking photos and saving them on the album) works perfectly and so did the PokeFinder when I moved on to Pokemon Sun, but it was only recently that this happened in Ultra Sun. So I did a bit of messing around with the Alola Photo Club (required story stuff since I’m new to the sequels) and I actually saved a random photo I took, then afterwards I closed the game without saving and now I’m regretting it because I believe the fact the SD card not being recognized is now present on all 3DS games that requires the use of an SD card as well (including gen 6 Pokemon games as I mentioned Pokemon Y) so I’ve been doing a bit of research looking into the issue and I think it was the forums on this website that says you need to restart your PC or laptop or just restart the game (not just hit the reset button but literally restarting the whole game from the very beginning if I’m correct?) and to right click ‘Open Extra Save Location’ folder and move the contents elsewhere if that doesn’t work then try something else? I mean, I don’t know what to do exactly as I NEVER want to lose my entire save states or save data of the games so if anyone can support me please do so now as I’m having the very same problem with other users in the forums about the SD card not being recognized at all (I also have the DCIM folder in the ‘sdmn’ or whatever it’s called folder from user\my-name\AppData\Citra\Roaming)

You can try the method above. Before you do so, we need to port your save file over. Start citra normally. Then right click on your game and select Open Save Data Location. This should open the folder containing your main file. Copy and paste this file to your desktop for now.

Now Follow the steps from my quote. Make sure to run your game from that portable citra version once before proceeding (that will have citra make the save folder structure), then right click on your game inside the portable citra and select ‘‘open save data location’’. Then you simply cut/copy-paste-and-replace the main file in that folder with the main file from your desktop. Now you should be able to launch your save file from the portable citra version and test if it works.

Nope that didn’t work. You said that I must cut, copy, paste and replace the main file in the folder that contains the manually downloaded Citra qt application with the main file from my desktop right? Well what I did was; I cut the main file in THAT folder (the one I just unzipped) then on my desktop I copied and pasted the main that I dragged and dropped from the original save to the other Citra qt application file where I also inserted the other 3DS games onto, but when I loaded Ultra Sun on qt with my current save data the SD card not being recognised still shows up. I’m pretty sure that in the sdmn folder the ‘DCIM’ folder MUST also be inside of it but I only see ‘Nintendo 3DS’ instead so I definitely messed something up.

Or maybe I should have copy-pasted the main file on desktop and then uninstall Citra and the 3DS games that require SD card usage then reinstall them am I correct or will I lose everything such as game progress?

You seem to have misunderstood a couple of the steps. I said cut/copy (I used a “/” because either would work, not because it’s an extra step).
When you first install the portable citra version (this includes creating a folder called user in that portable citra folder), it hasn’t created any folder structure in the user folder yet. Running a game will ensure that happens, however, this will also create a main file. Even if you hadn’t saved your game yet. So when you select open save data loction in the portable citra, it will show there’s already a main file there. That main file needs to be replaced by your normal save file.
As for uninstalling citra, there’d be no point to that. Your rom, the citra program and your save files are all seperate from one another. The folders containing your save files wouldn’t be deleted. Likewise, folders such as DCIM and Nintendo 3DS also wouldn’t be deleted.
Please make sure you followed my steps correctly and get back to me. If it still doesn’t work, please upload your main save file so I can attempt to recreate the issue on my end (you’ll have to use something like google drive to upload it)

I followed every steps and still doesn’t work.
I now have uploaded the main save file to Google Drive but I’ve never really used it for uploading things, mainly for storing documents and files so I don’t know how to send it to you if your allowed to email me via Drive?

You should be able to get a link for me to your file. Post the link in this channel and make sure it’s not set to private.

Here’s the link: https://drive.google.com/file/d/1EKguhz1zX8OOZtvfd7cqRF6RbmtoSf4f/view?usp=sharing
I’m not sure if the lack of SD card thing works for you but it doesn’t for me in my case.

Alright, I’ll test it out as soon as I have the time!

1 Like

Which citra version did you test your save file on? Edit:I figured out the save file was for ultra sun xD