Pokemon Ultra Sun Won't Launch

#1

Every Time I Run Pokemon Ultra Sun Using Citra, it crashes without any error or log info.

About 7 months ago I played Pokemon Ultra Sun for several hours and it all worked well, but today I wanted to play it again, just to find out that whenever I try to launch it, Citra crashes without any errors, nor does it write anything in the log file. I updated all graphic drivers, but it changed nothing.
I changed the resolution to “native” and it suddenly started! Then I changed it to ANYTHING ELSE, which causes it to crash (Just like I described) .

System Information

  • Operating System: Windows 10
  • CPU: Intel Core I7-7700 3.6 GHz (8 CPUs)
  • GPU: Nvidia Geforce GTX 1070 (8gb)
  • Citra Version: Citra Nightly 826
  • Game: Pokemon Ultra Sun
#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

#3

Follow the bot instructions properly and you should have a log. make sure that Global Log Filter is set to *:Info

#4

I did everything perfectly, yet nothing happens. I’m pretty sure that I tried every possible option.

#5

Do it in order to avoid mistakes.

  1. Open citra, go to Emulation > Configure > Debug and click on Open Log Location, leave that folder open.
  2. Launch your game, wait until your issue is reproduced, after that close citra. (don’t open again)
  3. Go to that folder that you leave opened and upload the citra_log.txt file.

if that doesn’t work, manually download the latest nightly build and try again.

#6

I have tried this a few times with different builds, yet it still didn’t work (Maybe I’m just doing something wrong), but I have fixed the issue already. It was caused by Sound set to “auto”. I changed it to null and then switched it back midgame, now it works really well.
Sorry for wasting your time!!