Pokemon ultramoon does not run

When i open pokemon ultramoon and click to “continue game” the music of the area where i am (the battle tree) runs, but the image does not. When i try to start a new game, Kukui is gonna to ask my name and photo, but the image freeze and the game crashes. What can i do?

System Information

  • Operating System: Windows 10 home single 1903
  • CPU: intel® core i7-6500U CPU 2.50GHz
  • GPU:
  • Citra Version (found in title bar): Citra Nightly 1514
    Citra Canary 1706
  • Game: Pokemon UltraMooncitra_log.txt.txt (37.7 KB)
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1514 HEAD-96832a2
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics 520
OpenGL Version                                3.3.0
GPU Driver Version                            23.20.16.4973
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

All the config is in default

GPU Driver Version: Build 23.20.16.4973

This driver is outdated, you need to update.

Download and install igfx_win10_100.8141.exe from https://downloadcenter.intel.com/download/29530/Intel-Graphics-Windows-10-DCH-Drivers?product=88194
direct link: https://downloadmirror.intel.com/29530/a08/igfx_win10_100.8141.exe

Also do this:

  1. File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

I already tried to delete the opengl folder. the error persists. What should I do?

Did you update the drivers that I linked you?

The system doesnt let me update it

Can you tell me what it says? They should be unlocked drivers.

We might need to update to 6373 manually first before 8141 but I was hoping it would finally work right away.

It says “the driver that you are installing is not validated for this system. get the right driver by the manufacturer of the system. it will come out of the program installation”

Ah, Intel lied :confused:

Ok do this:
Download win64_25.20.100.6373.zip from https://downloadcenter.intel.com/download/28289/Intel-Graphics-Driver-for-Windows-10
direct link: https://downloadmirror.intel.com/28289/a08/win64_25.20.100.6373.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

After that you should be able to install 8141

My computer has a radeon graphics. Can i continue?

Yes, it might even run better than Radeon because AMD has poor OpenGL drivers on Windows. If you want to run Radeon you need to change Switchable Graphics in Radeon Settings to “high performance”. Citra detected your iGPU not Radeon last time.

i have installed the intel 6373 and it worked! If in next updates the bug comes back, do i have to install the 8141?

It’s recommended to update to 8141 now to get the optimizations made since they moved to DCH drivers.