Pokemon UltraSun crashes at startup

Issue:
Since some days, Citra crashes down when I launch Pokemon Ultra Sun while everything is ok with Ultra moon.
I played some weekd (had arount 100 pkmn).
I copied the backup on another computer and everyting is ok so it’s not the backup or the rom but something on my computer.
I tried to uninstall and reinstall Citra, no success.
I tried to install Canary version : no success

In the log file, I’ve found that the error arrives when starting Service.HTTP. But it’s ok for Pokemon Ultra Moon.
The last sucessfull launchs of pkmn Ultra Sun, I had more than 1500 shaders, could it be the reason of the issue ?

Thanks in advance for your help !

System Information

  • Operating System: Windows 10 64bits
  • CPU: i5-3350P
  • GPU: Radeon RX 580
  • Citra Version (found in title bar): Nightly 1554 / Canary 1762
  • Game: Pokemon Ultra Sun
  • Screenshot of Issue (include the full Citra window including titlebar): nothing to show

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log_crash.txt (14.1 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1762 HEAD-d0ca49b
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-3350P CPU @ 3.10GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Hi, do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it’s there
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to slowly load all shaders from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

1 Like

Perfect !
Thanks for this solution.

1 Like