Pokemon ultrasun fps problems

Issue:
when i play pokemon ultrasun the fps go down and it goes very slow, the emulator usually runs between 5-12fps, sometimes it goes up dramatically.
I have tried other games and they work correctly.
I’m not sure if it’s due to a configuration error file, a rom problem, or just a problem with my PC.

System Information

  • Operating System: windows 10 x64
  • CPU: AMD Ryzen 3 3200u with radeon vega mobile gfx
  • GPU:
  • Citra Version (found in title bar): citra nightly 1697
  • Game: pokemon ultrasun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (36.3 KB)

System Information for Support

Client Version                                Nightly 1697 HEAD-b3cab3c
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 3 3200U with Radeon Vega Mobile Gfx  
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon(TM) Vega 3 Graphics 
GPU Driver Version                            19.40.46 26.20.14046.3
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

See Fire emblem fates problem CPu fps - #6 by tywald.

well, I don’t know if I can do a dual boot, because when I tried it, my pc was suffering from certain problems.

also my first language is not English and I do not speak it fluently, so I cannot understand several things in the video.

thank you very much, but sadly that doesn’t help me.

You can try turning on Hardware Shaders in Emulation>Configuration>Graphics>Advanced Tab. But this setting is a bit hit or miss for AMD GPUs. It might increase performance, but it may also decrease performance.

yes, that improves the fps a bit, now it goes between 18-25 fps.

I had turned it off because with other games it decreased the fps.

I Could do another thing?