Pokemon US running at 0 speed and fps, black screen or freezes at title

Issue:
As of a few days ago, I was having no trouble whatsoever playing the game. The typical crashes from time to time, but it was nbd. But once I updated Canary to 1775, US stopped loading completely for a while. I’d get a black or grey set of screens and everything would drop to 0 speed and 0 fps. I’ve tried using nightly, tried downloading canary 1774 (the last version to run the game properly), deleted the opengl file, tried totally uninstalling and re-installing Citra, updated my GPU, uninstalled and reinstalled again, went to as many forum threads as I could with similar issues, and after a little bit of messing around I got it to the point where I can get onto the loading screen, but I can’t select anything, it immediately freezes up. And it’s gone back to just black now. I’m hoping there’s something someone can help with, be it an oversight on my end or my computer just not running things right. Any help is appreciated.

System Information

  • Operating System: Windows 10
  • CPU: Intel® Pentium® CPU N3540 @2.16GHz 2.16GHz
  • GPU: Intel® HD Graphics
  • Citra Version: Citra Canary 1783
  • Game: Pokemon Ultra Sun/Ultra Moon
  • Screenshot of Issue:

Diagnostic Log
citra_log.txt (13.0 KB)

System Information for Support

Client Version                                Canary 1783 HEAD-d66aab1
Operating System                              Windows 10 (10.0)
CPU                                                 Intel(R) Pentium(R) CPU  N3540  @ 2.16GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics
GPU Driver Version                            10.18.10.4276
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

GPU Driver Version: Build 10.18.10.4276

This driver is outdated, you need to update.

Download win64_15.33.50.5129.zip from https://downloadcenter.intel.com/download/29473/Intel-Graphics-Driver-for-Windows-15-33-?product=85552
direct link: https://downloadmirror.intel.com/29473/a08/win64_15.33.50.5129.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Also do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it’s there
  3. Emulation->Configure... then click on Graphics on the left
  4. Enable Disk Shader Cache
  5. Click on the Advanced tab and turn on Hardware Shader

Since you have an old GPU which can randomly crash due to a driver bug you might need to use Nightly 1392 until you upgrade your computer as it is the last build before the Split Presentation Thread change: https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1392