Pokemon X BUG can help me fix it?

Issue:
The game start fine and everything, just little lag in some demanding scenes (like the intro but the rest of the game run excelent), but after the Xana Battle at the begining the game freezes, and dont show my character (its kinda T-posing in the other side of the scenario where the camera is not looking) and i dont know what to do, other games run fine

System Information

Diagnostic Log
citra_log.txt (183.0 KB)

System Information for Support

Client Version                                Nightly 1737 HEAD-28039d3
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz | AVX
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.5161
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics

I know this is a Bot and cant answer me, but that its strange, i have installed the last Intel HD driver recently…

no, the oficial intel page say that those are the most recent drivers

Because your iGPU has driver bugs, you’ll need to use an older version of Citra in order to prevent random freezing and crashing from occurring until you upgrade your hardware:
Download citra-windows-mingw-20191214-ddb7ead.7z from Release nightly-1392: Merge pull request #5020 from jroweboy/dynamic-mf · citra-emu/citra-nightly · GitHub
Extract it using Winrar or 7zip. Put the extracted folder anywhere you want. Now run citra-qt.exe from the folder and run your game.

I tried and the game run better, but the bug persist, i have recorded it with the movie tool on citra but i dont know how to pass you the archive…

Maybe the solution its a save file that skip that battle

You also appear to be dumping textures, which might be contributing to the issue. Go to Emulation>Configuration>General and press Reset All Settings.

i have done it and the bug still persist

Please upload a log file.

citra_log.txt (272.2 KB)

System Information for Support

Client Version                                Nightly 1392 HEAD-ddb7ead
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.5161
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

There is nothing we can do?

I don’t see what else could cause this other than a badly edited ROM (randomization/romhack) or cheat codes/save file edits. Are any of these things relevant to your situation? If not, the save data might have gotten corrupted when you were using it on recent Citra versions (which don’t support your iGPU because of the bugs it has).

Well in that case i will see if i can solve the problem by myself, sorry for the problems :sweat_smile: