Pokemon X on macos

Issue:
I’m playing pokemon X, the game becomes super slow everytime the camera moves and Citra crashes after I use the first move in the first battle (if hasnt already crashed before, when mons get out of the balls for example). I read in many topics that Pokemon on citra is not working decently yet, I also read that some people could play it enjoyably. My problem is, I can’t even play. I tried deactivating the disk shader in options but nothing changed. Help? Ty

System Information

  • Operating System: macOS mojave 10.14.6
  • CPU: 2.3 Ghz intel core i7
  • GPU: Intel iris pro 1536 mb
  • Citra Version: nightly 1550
  • Game: Pokemon X

Diagnostic Log
citra_log.txt (4.3 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Try these builds:

https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1540
https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1539

https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1393
https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1392

Let me know which ones work.

Sorry if I’m not expert in computer sciences, how to try them? Clicking a osx of them opened another emulator in my mac (a GBA one, however).

Download the .tar.gz file and extract it somewhere, then open its citra-qt. Might be in a subfolder.

While the 1540 had no impact, the 1539 works quite well; with some graphic bugs, like pokemon in black and white for a second when they come out of the balls, but decently. 1393 and 1392 work well too, especially 1392 which looks like the best of all four, but these 2 have no music, only audio effects (buttons sounds, pokemon moves sounds).
If I am right, you can’t even save states (from emulator, not from game) with these builds but yet, I can play now. So TY very much

On 1540 can you try enable or Separable Shader? Or disable both Hardware Shader and Separable Shader.

Since 1540 this change was added:

Enabling separable shader made the screen go completely crazy, with flashes of all colors. Disabling both maybe made a very small difference, or maybe didnt, but it’s not as good as 1539 at all.

Ok, if you disable Hardware Shader but enable Separable Shader what happens? One of the combinations should be the same as it was in 1539.

If none works I will try bring this up.

As you can see in the screenshot of the advanced graphics options in mac you linked me, you can’t enable separable shader if you disabled hardware shader. Only after enabling this one, you can then enable Separable shader. So I couldn’t try this combination.
The only way to enable separable shader is to keep both active and when I do, a message appears, telling me separable shader is “broken on mac with intel gpu” and that the graphics will go wild with stuff like black screen, which is what actually happens.

I see. What year is your mac from and what model? Go to Apple menu then About This Mac.

MacBook Pro (Retina, 15-inch, Late 2013)

1 Like