Pokemon X - Pokemon textures glitching out

Issue:
When booting up Pokemon X, the game will sometimes randomly glitch out the pokemon textures after a certain period of time, as shown below. This does not happen at the start of the game, and only happens after opening up a saved file after a certain period of time.

System Information

  • Operating System: Windows 10
  • CPU: Intel(R) Core™ i7-6500U CPU @ 2.50GHz | AVX2 | FMA
  • GPU: Intel(R) HD Graphics 520
  • Citra Version (found in title bar): Citra Nightly 1777
  • Game: Pokemon X
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (82.5 KB)

System Information for Support

Client Version                               Nightly 1777   HEAD-bf6e4a4
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            Intel(R) HD Graphics 520
GPU Driver Version                           20.19.15.4326
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics

I updated my drivers, but now the emulator crashes whenever I attempt to open the rom.
It seems like something’s going wrong with the shaders.

Diagnostic Log
citra_log.txt (10.8 KB)

System Information for Support

Client Version                               Nightly 1777   HEAD-bf6e4a4
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz | AVX2 | FMA
Graphics API                                 Unknown (?)
Graphics Renderer                            ?
GPU Driver Version                           ?
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

I did not find anything wrong in your log file. Please wait for a human moderator to assist.

Go to File>Open Citra Folder, then open up the shaders folder and delete the opengl folder found here. Now try your game again.

This does not seem to have fixed the issue. It’s still crashing upon an attempt to launch the rom, unfortunately.

Here’s the log file:
citra_log.txt (16.4 KB)

System Information for Support

Client Version                               Nightly 1778   HEAD-a51b1cd
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            Intel(R) HD Graphics 520
GPU Driver Version                           20.19.15.4463
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics

The drivers don’t appear to be updated at all. Please follow the steps I gave you earlier again.

Also, I wasn’t aware of a crashing issue?