Pokemon X running at very slow speeds

Pokemon X running at very slow speeds

I have managed to get Pokemon X to work but unfortunately it runs at no faster than 15 frames a second and often as low as 10 or 5fps during moderately intense moments. the game is basically unplayable.

  • System Information*
  • Operating System: Windows 10
  • CPU: Intel Core [email protected]
  • GPU: Intel HD Graphics 620
  • Citra Version (found in title bar): Citra Nightly 1757
  • Game: Pokemon X
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (174.1 KB)

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

System Information for Support

Client Version                               Nightly 1757   HEAD-ac98458
Operating System                             Windows 8 (6.2)
CPU                                          Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz | AVX2 | FMA
Graphics API                                 OpenGL 3.3.1
Graphics Renderer                            Radeon (TM) R7 M445
GPU Driver Version                           19.50.26 26.20.15026.1
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

Try setting Citra to run on your integrated Intel GPU instead of your dedicated AMD Radeon one. AMD’s OpenGL drivers on Windows are sadly hot garbage, which causes slowdowns in OpenGL based apps like Citra: https://www.amd.com/en/support/kb/faq/dh-017

I tried getting to run on the Intel GPU instead but it doesn’t seem to make much of a difference, in fact i think it might be slightly worse in terms of frame rate!

That might be because you don’t have the latest GPU drivers for it installed. Please upload a log file after running Citra on your Intel iGPU. The log file should tell me what driver version you’re on.

citra_log.txt (542.6 KB)

System Information for Support

Client Version                               Nightly 1757   HEAD-ac98458
Operating System                             Windows 8 (6.2)
CPU                                          Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            Intel(R) HD Graphics 620
GPU Driver Version                           27.20.100.8854
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [ ]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [ ]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics
  • Please enable the Vsync option if you are experiencing screen tearing.

Ah, a settings issue. Go to Emulation>Configuration>Graphics>Advanced tab and enable both Hardware Shaders and Shader JIT. Now try your game again. It should be notably faster now.

Thank you. The game now runs significantly better and is mostly playable. Usually it is running between 75-85% instead of 40% at best but it still has moments where it slows down, especially when entering a new screen in game. This can send the frame rate to 0 for a while as it loads and is very annoying as this happens whenever i enter a new building or start a pokemon battle in game.

citra_log.txt (525.8 KB)

System Information for Support

Client Version                               Nightly 1757   HEAD-ac98458
Operating System                             Windows 8 (6.2)
CPU                                          Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            Intel(R) HD Graphics 620
GPU Driver Version                           27.20.100.8854
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics

I’m afraid that some of that stutter is unavoidable, as that happens even on very powerful hardware. Has to do with how pokemon games use CRO loading/unloading for every transition.

Though, I had expected that you would be able to run at 100% speed most of the time. Your CPU + iGPU should be able to manage that much. Are you running Citra whilst your laptop is not being charged? Most laptops “clock down” their hardware’s performance when not connected to wall power to save on battery, if it’s doing that in your case, it could explain the discrepancy in performance.

Other than that, you might have to update to at least Windows 10 in order to get the latest driver updates for your iGPU. Which I would recommend anyways since Windows 8(.1) doesn’t get any security updates anymore.