Pokemon X running below 50% speed at 15 FPS

Issue:
Enter a description of your issue here, in full detail.
I just got the Dell XPS 15 9570 today and wanted to get citra and use my 3ds pokemon x game in citra. It works perfectly fine on my old Microsoft surface book. This is a really good computer and I cant figure out why it can’t run as fast.

System Information

  • Operating System: Windows 10 version 1803
  • CPU: Intel Core i7 - 8750H CPU @ 2.20 GHz 2.21GHz
  • GPU: Nvidia Geforce GTX 1050 Ti Max-Q
  • Citra Version (found in title bar): Citra Canary 1389
  • Game: Pokemon X
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
<citra_log.txt (39.2 KB) >

System Information for Support

Client Version                                Canary 1389 HEAD-f14d36d
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1050 Ti with Max-Q Design/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [ ]
Enable Shader JIT                             [ ]
System Region                                 [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Turn off Battery Boost in GeForce Experience.

Also make sure you have set Power management mode in Nvidia Control Panel to either Adaptive or Prefer maximum performance.

I have done the power management mode thing in nvidia control panel and I turned off battery boost in the Geforce Experience. I even went so far to reinstall Geforce Experience. Still it is running at 50% speed at an average 15 FPS. Is this case unusual for someone like me. My computer is really good with specs capable running this program.

What is your frametime like? (It’s right next to the fps counter, measured in ms).
I have seen this issue before and it was caused by Battery Boost being enabled which would cut your fps in half.

Make sure you have the latest drivers, from the log you had 397.93 while latest is 431.36

[Post Removed By Moderator]

Please don’t post links to unofficial builds. Aside from often shipping with copyrighted files they can’t legally distribute, these can contain malicious code or outdated functions which will break games.

Ok so i finally updated my drivers and reinstalled them just to be sure and everything runs smoothly; however, i get more lag spikes than usual. I don’t know if its because im on citra Canary or what but I just wanted to let you know that know. To be clear as to what i did( just in case for any future reference):

  1. Updated my Nvidia Drivers
  2. Reinstalled Nvidia GeForce and turned off battery boost
  3. Went to Nvidia Control Panel and turned on adaptability(prefer maxium performance makes the game lag even more)

Thank you to all the people who contributed to my questions. I really appreciate Citra having an amazing community who actually helps out! Please close this forum.

It’s probably shader compilation stutters, they should become less the longer you play.

So you can finally reach 100% speed now or?