Pokemon X won't run properly as soon as game starts

#1

Issue:
So I was trying to play some pokemon games on my laptop but I had trouble. At first I started playing pokemon sun which kinda worked better (?) but still not good at all, some animations weren’t even showing.

So I switched to an older version: Pokemon X. I thought this might work however as soon as the game actually starts when the professor is “talking” to me or the story that starts (animation) I get a black screen with occasional white “lightnings” and weird triangular shaped white forms that quickly appear and disappear.

My computer is unfortunately a little bit old, around 4-5 years (there might also be a hardware problem wth my RAM but not sure)

System Information

  • Operating System: Windows 8.1, 64 bits
  • CPU: Intel Core i5, 2.60 GHz
  • GPU: 4,00 GB RAM, AMD Radeon HD 7500M/7600M Series
  • Citra Version (found in title bar): Citra Nightly 1268
  • Game: Pokemon X

Diagnostic Log
Log is gonna be uploaded any second

#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

#3

citra_log.txt (4.3 KB)

#4

System Information for Support

Client Version                                Nightly 1268 HEAD-af197c1
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
#5

tried it, didn’t change anything.
BTW my graphic card: AMD Radeon HD 7500M/7600M Series

#6

Another update: I disabled hardware shader and it was a bit better. I was able to read some texts and see some backgrounds (within pokemoon sun). However, WHENEVER there is an animation coming, of a professor or a pokemon at the beginning, THAT part of the screen turns black or brown while the sound is still running and the other parts of the graphics (that are static for example or parts where I just enter my name) are working.

It looks like wherever there is actual 3d animation involved, this part will NOT get shown within my emulator. WHY is that?! Does it have something to do with my GPU?

#7

OK, problem solved. I updated my GPU driver AND activated hadware shader.
It works now.

There are just two smaller issues currently: the game lags a bit when I am in a city with a lot of 3d graphics. But the lagging is OK, it’s not that heavy, the only thing that annoys me is the lagging sound. What can I do about THAT? If the sound would be smooth then everything would be awesome